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1 Introduction

Copyright (C) 2019, Daniel H. Huson

Community Edition: The Community Edition of this program is free software: you can redistribute it
and/or modify it under the terms of the GNU General Public License as published by the Free Software
Foundation, either version 3 of the License, or (at your option) any later version.

MEGAN Community Edition is distributed in the hope that it will be useful, but WITHOUT ANY WAR-
RANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
PURPOSE. See the GNU General Public License for more details.

You should have received a copy of the GNU General Public License along with this program. If not, see
http://www.gnu.org/licenses.

A paper describing the Community Edition is under review and upon acceptance the source files will be
made available at http://github.com/danielhuson/megan-ce.

Ultimate Edition: The Ultimate Edition of this program is licensed by Computomics GmbH for a fee. The
Ultimate Edition is based on the Community Edition and includes additional, proprietary code, which is not
open source.

MEGAN Ultimate Edition is distributed in the hope that it will be useful, but WITHOUT ANY WAR-
RANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
PURPOSE.

You should have received a copy of the MEGAN Ultimate Edition License along with this program.

Type-setting conventions: In this manual we use e.g. Edit→Find... to indicate the Find... menu item
in the Edit menu.

UEInformation about functionality only available in the Ultimate Edition is labeled UE in the margin.

How to cite: If you publish results obtained in part by using MEGAN, then we require that you acknowledge
this by citing the program as follows:

• D.H. Huson et al, MEGAN Community Edition - Interactive exploration and 2 analysis of large-scale
microbiome sequencing data, PLoS Computational Biology 12(6): e1004957. doi:10.1371/journal.
pcbi.100495 [11]

The term metagenomics has been defined as “The study of DNA from uncultured organisms” (Jo Han-
delsman), and an approximately 99% of all microbes are believed to be unculturable. A genome is the
entire genetic information of one organism, whereas a metagenome is the entire genetic information of an
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ensemble of organisms. Metagenome projects can be as complex as large-scale vertebrate projects in terms
of sequencing, assembly and analysis.

The aim of MEGAN is to provide a tool for studying the taxonomic content of a set of DNA reads, typically
collected in a metagenomics project. In a preprocessing step, a sequence alignment of all reads against a
suitable database of reference DNA or protein sequences must be performed to produce an input file for
the program. MEGAN is suitable for DNA reads (metagenome data), RNA reads (metatranscriptome data),
peptide sequences (metaproteomics data) and, using a suitable synonyms file that maps SILVA ids to taxon
ids, for 16S rRNA data (amplicon sequencing).

At start-up, MEGAN first reads in the current NCBI taxonomy (consisting of over one million taxa). A first
application of the program is that it facilitates interactive exploration of the NCBI taxonomy.

However, the main application of the program is to parse and analyze the result of an alignment of a set of
reads against one or more reference databases, typically using BLASTN, BLASTX or BLASTP or similar
tools including DIAMOND to compare against NCBI-NT, NCBI-NR or genome specific databases. The
result of a such an analysis is an estimation of the taxonomical content (“species profile”) of the sample
from which the reads were collected. The program uses a number of different algorithms to “place” reads
into the taxonomy by assigning each read to a taxon at some level in the NCBI hierarchy, based on their hits
to known sequences, as recorded in the alignment file.

Alternatively, MEGAN can also parse files generated by the RDP website [7] or the Silva website [21].
Moreover, MEGAN can parse files in SAM format [13]. Note that DIAMOND [5] and MALT produces
SAM format for BLASTX-like alignments and MEGAN is able to parse this, see also sam2rma.

MEGAN provides functional analysis using a number of different classification systems. The InterPro2GO
viewer is based on the Gene Ontology metagenomic goslim [2] and the InterPro database [15]. The eggNOG
viewer is based on the “eggNOG” database of orthologous groups and functional annotation [20].

the SEED classification [18] and

The Community Edition of MEGAN provides only an early 2011 version of the KEGG classification [12].

UEThe Ultimate Edition of MEGAN contains an up-to-date version of KEGG, including all pathway files.

An early version of this software (called GenomeTaxonomyBrowser) was used to analyze metagenomic
reads in the very first paper to use second-generation sequencing for metagenomics [19].

This document provides both an introduction and a reference manual for MEGAN. Further help is provided
by the MEGAN Community website found at http://megan.informatik.uni-tuebingen.de.
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2 Getting Started

This section describes how to get started.

First, download an installer for the program from
www-ab.informatik.uni-tuebingen.de/software/megan6, see Section 3 for details.

Upon startup, the program will automatically load its own version of the NCBI-taxonomy and will then
display the first three levels of the taxonomy. To explore the NCBI taxonomy further, leaves of this overview
tree can be uncollapsed. To do so, first click on a node to select it. Then, use the Tree→Uncollapse
item to show all nodes on the next level of the taxonomy, and use the Tree→Uncollapse Subtree
item to show all nodes in the complete subtree below the selected node (or nodes).

To analyze a data set of reads, first BLAST the reads against a database of reference sequences, such as
NCBI-NR [3] using BLASTX [1] or BLASTP, NCBI-NT [3] using BLASTN [1]. In addition, the output of
a number of other programs can also be parsed, for example, RAPSearch2 [24].

Then import the BLAST file into MEGAN using the File→Import From BLAST... menu item.
The Files Tab allows you to enter the name of the BLAST file, a reads file containing all the read sequences
in multi-FastA format (if available), and the name of the new output RMA file. As of version 4, you can
also specify more than one BLAST file and one more than one reads file.

Alternatively, instead of supplying a BLAST file, one can also specify a file obtained from the RDP website
or from the Silva website. In addition, MEGAN can also parse files in SAM format.

Some implementations or output formats of BLAST and similar tools suppress those reads for which no
alignments were found. In this case, use the Options→Set Number Of Reads... menu item to
set the total number of reads in the analysis.

Clicking on a node will cause the program to display the exact number of hits of any given node, and the
number of hits in the subtree rooted at the node. Right-clicking on a node will show a popup-menu and
selecting the first item there, Inspect , will open the Inspector window which is used to explore the
hits associated with any given taxon. A node is selected by clicking on it. Double-clicking on a node will
select the node and the whole subtree below it. Double-clicking on the label of a node will open the node in
the Inspector window.

Example files are provided on the public MeganServer. The use of MeganServer is explained in Section 33
for details.

3 Obtaining and Installing the Program

MEGAN is written in Java and requires a Java runtime environment version 11 or later, freely available from
www.java.org. Note that the Windows and MacOS X installers both contain a bundled JRE and so separate
installation of Java should not be necessary for these two operating systems.

MEGAN is installed using an installer program that is available from
www-ab.informatik.uni-tuebingen.de/software/megan.
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3.1 Installers for the Community Edition

There are three different installers for the Community Edition, targeting different operating systems:

• MEGAN_COMMUNITY_windows-64x_6.21.2.exe provides an installer for a 64-bit version of
MEGAN for Windows.

• MEGAN_COMMUNITY_macos_6.21.2.dmg provides an installer for MacOS X.

• MEGAN_COMMUNITY_unix_6.21.2.sh provides an installer for Linux and Unix.

3.2 Installers for the Ultimate Edition

There are three different installers for the Community Edition, targeting different operating systems:

• MEGAN_Ultimate_windows-64x_6.21.2.exe provides an installer for a 64-bit version of
MEGAN for Windows.

• MEGAN_Ultimate_macos_6.21.2.dmg provides an installer for MacOS X.

• MEGAN_Ultimate_unix_6.21.2.sh provides an installer for Linux and Unix.

The 32-bit Windows version of MEGAN is configured to use 1.1 GB of memory. For all other versions
of the software, the installer will allow you to set the maximal amount of memory during the installation
process. By default, the program will suggest to use 2 GB. If your computer has more memory available,
then it is a good idea to set this limit higher. For example, if you have 4 GB of main memory, then set the
limit for MEGAN to 3 GB. This is because the program runs faster, the more memory it is given. To change
the maximum amount of memory used after installation of the program, see Section 37.

To install MEGAN using a command-line dialog, launch the installer from the command line and pass the
command-line option -c. For example, under MacOS X, type the following:

/Volumes/MEGAN/MEGAN\ Installer.app/Contents/MacOS/JavaApplicationStub
-c

4 Program Overview

In this section, we give an overview over the main design goals and features of this program. Basic knowl-
edge of the underlying design of the program should make it easier to use the program.

MEGAN is written in the programming language Java. The advantages of this is that we can provide versions
that run under the Linux, MacOS, Windows and Unix operating systems.

Typically, after generating a RMA file (read-match archive) from a BLAST file, the user will then in-
teract with the program, using the Find toolbar to determine the presence of key species, collapsing or
un-collapsing nodes to produce summary statistics and using the Inspector window to look at the de-
tails of the matches that are the basis of the assignment of reads to taxa. The assignment of reads to taxa
is computed using the LCA-assignment algorithm, see [10] for details. In addition to taxonomic binning,
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MEGAN also allows functional analysis. Another main feature is the comparison of samples. There are a
number of tools for graphing data, and for import and export of data.

The Community Edition of MEGAN provides a graphical user interface to allow the interactively explore
and analyze their samples.

UEThe Ultimate Edition provides a graphical user interface with a number of additional features. Moreover,
the Ultimate Edition provides a command-line mode, in which the program reads commands from a file or
from standard input and writes output to files or to standard output. The usage of command-line mode is
described in Sections 35 and 36.

5 Importing, Reading and Writing Files

To open an existing RMA file or MEGAN file, select the File→Open... menu item and then browse
to the desired file. Alternatively, if the file was recently opened by the program, then it may be contained in
the File→Open Recent submenu.

By default, when parsing an input file, for each read, taxon and RefSeq id, only one best-scoring match
is kept. For example, if read R has two equally high-scoring matches M1 and M2 to two sequences
from E. coli, say, then MEGAN will discard one of the two matches, unless they have different RefSeq
accession numbers, or unless exactly one of the two matches does not have a RefSeq accession number.

UETo turn this filter off, use the Window→Command Input... menu item to enter the following
command setProp oneMatchPerTaxon=false.

5.1 Blast Files

New input to the program is usually provided as a BLAST file obtained from a BLAST alignment of the
given set of reads against a reference database such as NCBI-nr or NCBI-nt, see Section 34 for details of the
file formats used. MEGAN supports BLASTN, BLASTX and BLASTP standard text-format, and BLAST
XML format as well as multiple output formats provided by tools similar to BLAST, like RapSearch2 and
DIAMOND.

The BLAST files and reads files may also be parsed in gzip format or zip format. In this case, the file names
should have concatenated suffixes ending on .gz or .zip, such as .blastn.gz or .fna.zip.

MEGAN can also parse tabular BLAST output (generated using BLAST option -m 8, however as this
form of output does not contain the subject line for sequences matched, it is unsuitable for MEGAN because
MEGAN cannot determine the taxon or gene associated with the database sequence. However, if you add
an additional column to this format containing the associated taxon name or numerical NCBI taxon-id for
each line then MEGAN will parse these and use them as input. For unknown taxa, write either unknown
or -1 in the column.

Note that, in all cases, the reads file should be given to use the full potential of the program.

The BLAST file and reads file are supplied to MEGAN when setting up a new MEGAN project . Both
files are parsed and all information is stored in the project file. The input data is then analyzed and can be
interactively explored. All reads and BLAST matches are contained in the project file and MEGAN provides
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different mechanisms for extracting them again. A MEGAN project file contains all reads and all significant
BLAST matches (by default, up to 100 matches per read) in a binary and incrementally compressed format.
The size of such a project file is around 20% of the size of the original input files and is thus usually smaller
than the file that one obtains by simply compressing the BLAST file. MEGAN provides control over whether
and how BLAST matches and reads are stored, see the discussion of the Import Blast window.

MEGAN5 uses a new algorithm for determining the taxon associated with a given reference sequence. In
previous versions, the program looked in the header line of a reference sequence for the longest substring
that matches some valid taxon name (or synonym) in the NCBI taxonomy. This determined which taxon to
assign to the match. However, because many entries in the NR database mention multiple different species
for a given match, the program now determines only maximal matching names in the header line and assigns
the match to the LCA of the taxa mentioned. (So, in particular, the LCA algorithm is used twice in MEGAN,
namely once to figure out which taxon to assign to a match and then, based on this, again to determine which
taxon to assign to a given read.)

Thus, it is important that alignment programs used in conjunction with MEGAN must list all taxa associated
with a given reference sequence.

5.2 SAM Files

MEGAN can now parse files in SAM format [13]. Note, however, that SAM files usually do not contain the
names of the taxa associated with the reference sequences and so one must supply suitable mapping files
that map identifiers used for the reference sequences to NCBI taxa and functional classes, see below.

5.3 DAA Files

MEGAN can parse files in DAA format [5]. Note, however, that DAA files usually do not contain the names
of the taxa associated with the reference sequences and so one must supply suitable mapping files that map
identifiers used for the reference sequences to NCBI taxa and functional classes, see below.

In addition, the daa-meganizer program can be used to addition classification data and all necessary indices
to a DAA files so that it can be opened directly in MEGAN. It can be found in the tools directory.

5.4 RDP Files

In addition, MEGAN can import rRNA analysis files downloaded from the RDP website at http://
rdp.cme.msu.edu/ [7]. Go to the website and upload your rRNA sequences and then let the website
process them for you. Please note that the RDP website allows one to download two types of files, namely
a hierarchy as text file from its Classifier :: Hierarchy View window and a text file obtained
from its Classifier :: Assignment Detail window. Input to MEGAN must be of the latter
type. The RDP website recommends using a Min Score setting of 80. MEGAN calls this the RDP-
Assignment-Detail format.

If you use the standalone RDP classifier, then the output has a different format. MEGAN calls this the
RDP-standalone format. In this case, MEGAN expects the format to be a tab-separated file in which
each line corresponds to one read:
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read-name [-] [taxon-name rank-name disjointScore] [taxon-name rank-name disjointScore] ...

In more detail, the first token is a string that identifies the read. The next token is either empty, or a minus,
in the latter case indicating that the read is reverse complemented. Then all further tokens come in groups of
three, indicating the name of a taxon, the name of the rank of the taxon and a disjointScore between 0 and 1
(which MEGAN will multiple by 100). MEGAN reports each such taxon as a separate hit for the read.

5.5 Silva Files

Similarly, MEGAN can import rRNA analysis files downloaded from the Silva website at http://www.
arb-silva.de [21]. To create a file using the Silva website that can be imported into MEGAN, go to
the Aligner tab of the Silva website and upload your sequences and then press the align sequences button.
Once the Silva website has computed an alignment, you will be able to download two files, an arb file and
a log file. MEGAN requires the log file as input, not the arb file. When importing such a file into MEGAN,
one must specify that MEGAN uses the synonyms file called silva2ncbi.map to map Silva accession
numbers to NCBI taxa. This file is available from the MEGAN download page.

5.6 CSV Files

MEGAN supports import of data from other programs in a delimiter-separated format (using comma’s or
tabs) from a CSV file.

5.7 BIOM Format Files

BIOM is a file format for exchanging data between different metagenome analysis tools. MEGAN can import
and export data in BIOM 1 format (based on the JSON format), see http://biom-format.org/.

Unfortunately, when upgrading the BIOM format to version 2, the authors of the format decided to base the
new format on HSF5, a technical framework for which no native Java implementation exists, making it very
difficult for Java developers to support version 2 of the BIOM format (and sadly, for no apparent benefit).
Hence, MEGAN currently does not support BIOM 2 format (based on the HSF5 format) or higher.

However, you can convert between BIOM 1 format and BIOM 2 format To convert BIOM2 format to
BIOM1, please use the conversion tool provided with the biom-format package at https://github.
com/biocore/biom-format.

One can for example import OTU classification data generated by the QIIME package [6], or taxonomic and
functional classifications generated by MG-RAST [9], using the Import→BIOM Format... menu
item. To export data in BIOM format, open the viewer for the type of data that you would like to export.
For example, if you want to export a SEED classification, then open the SEED Analyzer window and select
those nodes that you want to export. Then use the Export→BIOM Format... to save the data to a
file. The suffix of a BIOM file is .biom.
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6 Long Reads

MEGAN explicitly supports the analysis of long reads, by which we mean reads or other input sequences,
such as contigs, that are long enough to contain or cover more than one gene, ≤ 500 bp, say.

This mode must be set before MEGAN parses or meganizes input files, because it effects the way that input
files are processed. By default, MEGAN is based on the assumption that any given read covers at most one
gene and the top 25 (by default) assignments to the read are kept. In long read mode, MEGAN scans along
the read and keeps alignments based on local criteria (paper in preparation) .

MEGAN uses a modified Long Read LCA algorithm for performing taxonomic binning of long reads (paper
in preparation) and a modified modified best hit algorithm for performing functional binning, allowing more
than one gene to be called on any given read.

The Long Read LCA algorithm clusters alignments for a given long read by their location along the read.
Then, for each taxon to which the read has a significant alignment, we compute the total bit score for that
taxon which is obtained identifying the best alignment to that taxon in each cluster, and then forming the
sum of their bit scores.

UEA new long read inspector dialog allows the user to visualize and explore long reads annotated by all the
functional classifications provided by MEGAN or defined by the user.

7 Taxonomic Binning

By default, MEGAN uses the NCBI taxonomy for taxonomic binning.

7.1 The NCBI Taxonomy

The NCBI taxonomy provides unique names and IDs for over 660,000 taxa, including approximately 25,000
prokaryotes, 84,000 animals, 65,000 plants, and 17,000 viruses. The individual species are hierarchically
grouped into clades at the levels of: Superkingdom, Kingdom, Phylum, Class, Order, Family, Genus, and
Species (and some unofficial clades in between).

At startup, MEGAN automatically loads a copy of the complete NCBI and then displays the taxonomy as
a rooted tree. The taxonomy is stored in an NCBI tree file and an NCBI mapping file, which are supplied
with the program.

7.2 The NCBI-NR and NCBI-NT Databases

The NCBI-NR (“non-redundant”) protein sequence database is available from the NCBI website. It contains
entries from GenPept, Swissprot, PIR, PDF, PDB and RefSeq. It is non-redundant in the sense that identical
sequences are merged into a single entry.

The NCBI-NT nucleotide sequence database is available from the NCBI website. It contains entries from
GenBank and is not non-redundant. It contains untranslated gene coding sequences and also mRNA se-
quences.
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7.3 Assigning Reads to Taxa

The main problem addressed by MEGAN is to compute a “species profile” by assigning the reads from a
metagenomics sequencing experiment to appropriate taxa in the NCBI taxonomy. At present, this program
implements the following naive approach to this problem:

1. Compare a given set of DNA reads to a database of known sequences, such as NCBI-NR or NCBI-NT
[3], using a sequence comparison tool such as BLAST [1].

2. Process this data to determine all hits of taxa by reads.

3. For each read r, let H be the set of all taxa that r hits.

4. Find the lowest node v in the NCBI taxonomy that encompasses the set of hit taxa H and assign the
read r to the taxon represented by v.

We call this the naive LCA-assignment algorithm (LCA = “lowest common ancestor”). In this approach,
every read is assigned to some taxon. If the read aligns very specifically only to a single taxon, then it is
assigned to that taxon. The less specifically a read hits taxa, the higher up in the taxonomy it is placed.
Reads that hit ubiquitously may even be assigned to the root node of the NCBI taxonomy.

If a read has significant matches to two different taxa a and b, where a is an ancestor of b in the NCBI
taxonomy, then the match to the ancestor a is discarded and only the more specific match to b is used.

The program provides a threshold for the bit disjointScore of hits. Any hit that falls below the threshold
is discarded. Secondly, a threshold can be set to discard any hit whose disjointScore falls below a given
percentage of the best hit. Finally, a third threshold is used to report only taxa that are hit by a minimal
number of reads or minimal percent of all assigned reads. By default, the program requires at least 0.1% of
all assigned reads to hit a taxon, before that taxon is deemed present. All reads that are initially assigned
to a taxon that is not deemed present are pushed up the taxonomy until a node is reached that has enough
reads. This is set using the Min Support Percent or Min Support item.

Taxa in the NCBI taxonomy can be excluded from the analysis. For example, taxa listed under root -
unclassified sequences - metagenomes may give rise to matches that force the algorithm to
place reads on the root node of the taxonomy. This feature is controlled by Preferences→Taxon
Disabling menu. At present, the set of disabled taxa is saved as a program property and not as part of a
MEGAN document.

Note that the LCA-assignment algorithm is already used on a smaller scale when parsing individual blast
matches. This is because an entry in a reference database may have more than one taxon associated with
it. For example, in the NCBI-NR database, an entry may be associated with up to 1000 different taxa. This
implies, in particular, that a read that may be assigned to a high level node (even the root node), even though
it only has one significant hit, if the corresponding reference sequence is associated with a number of very
different species.

Note that the list of disabled taxa is also taken into consideration when parsing a BLAST file. Any taxa
that are disabled are ignored when attempting to determine the taxon associated with a match, unless all
recognized names are disabled, in which case the disabled names are used.
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7.4 Weighted LCA Algorithm

The weighted LCA algorithm is identical to the weighted LCA algorithm used in Metascope [4]. It operates
as follows: In a first round of analysis, each reference sequence is given a weight. This is the number of
reads that align to the given reference and that have the property that all the significant alignments for the
read are to the same species as the reference sequence (but can also be to a strain or sub-species below the
species node). In a second round of analysis, each read is placed on the node that is above 75% of the total
weight of all references for which the read has a significant alignment.

The Weighted LCA algorithm will assign reads more specifically than the naive LCA algorithm. Because it
performs two rounds of read and match analysis, it takes twice as long as the naive algorithm. Also, because
it must maintain a table of all references seen, it uses much more memory, on the order of 5-10 Gb.

8 Functional Analysis

MEGAN allows functional analysis using InterPro2GO, eggNOG, SEED and KEGG.

UEMEGAN Ultimate Edition allows the user to generate and use additional classifications.

8.1 Identification of InterPro Families

The InterPro2GO viewer implemented in MEGAN is based on the Gene Ontology metagenomic goslim [2]
and InterPro families [15].

The InterPro2GO classification is displayed as a tree containing about 26,000 nodes and edges. Reads are
mapped to InterPro families and these families are appear as leaves of a tree based on the metagenomic
goslim.

When parsing the results of sequence alignment of reads against a reference database, MEGAN can parse
identifiers of the form IPR123456. If these are not present in the file, then as an alternative, we provide
both a GI to InterPro and a RefSeq to InterPro mapping file on the download website.

8.2 Identification of SEED Functional Classes

The SEED classification of gene function consists of a collection of biologically defined subsystems [18].
The SEED classification can be displayed as a tree containing about 10,000 nodes and edges. Genes are
mapped onto functional roles and these are present in one or more subsystems. The program will attempt to
map each read onto a gene that has an known functional role and then into one or more subsystems.

To perform this analysis, MEGAN uses a mapping of RefSeq ids to SEED functional roles. Hence, if
a SEED-based analysis is desired, then the database that is used in the BLAST alignment must contain
RefSeq-ids. This is the case for the NCBI-NR database. The Import Blast dialog provides other
options for identifying SEED functional roles.
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8.3 Identification of COGs and ENOGs in eggNOG

The eggNOG classification of gene function consists of a collection of biologically defined clusters of
orthologous groups [22, 20]. The eggNOG classification can be displayed as a tree containing many nodes
and edges. Genes are mapped onto COGs and NOGs. The program will attempt to map each read onto a
gene that has an known COG or NOG.

To perform this analysis, MEGAN uses a mapping of RefSeq ids to COGs and ENOGs. Hence, if a COG-
based analysis is desired, then the database that is used in the BLAST alignment must contain RefSeq-
ids. This is the case for the NCBI-NR database. The Import Blast dialog provides other options for
identifying COGs.

8.4 Mapping of Reads to KEGG groups and pathways

The KEGG database provides a collection of metabolic pathways and other pathways [12]. The KEGG
classification can be displayed as a tree, which we refer to as the Kegg tree . Genes are mapped onto so-
called KO groups and these are present in one or more pathways. The program will attempt to map each
read onto a gene that has a valid KO identifier and thus to one or more pathways.

To perform this analysis, MEGAN uses a mapping of GI numbers to KO groups. Hence, if a KEGG-based
analysis is desired, then the database that is used in the BLAST alignment must contain GI numbers. This
is the case for the NCBI-NR database before September 2016. The Import Blast dialog provides other
options for identifying KO groups.

Due to KEGG licensing restrictions, the Community Edition of KEGG ships with an early
2011 version of the KEGG classification and KEGG pathways cannot be viewed in MEGAN.

UEThe Ultimate Edition comes with with a built-in, licensed version of the latest KEGG classification, includ-
ing pathway images, see Section 20.

8.5 Overriding MEGAN’s classification

You can override the assignments that MEGAN makes to functional classes as follows. Assume that you
meganized DAA file (or RMA6, similarly) file is called microbiome.daa. To override MEGAN’s KEGG
classification algorithm, say, provide a file called microbiome.kegg that is contained in the same direc-
tory as the DAA file. The file suffix must match the name of the classification you are overriding, in
lowercase letters. The file should containing a mapping between read names and their integer classification
ids, in a tab-spaced format. When computing or recomputing a classification, MEGAN (and related tools)
will check to see whether such a file exists and if it finds one, it will import the mapping and will use it when
classifying reads. Whenever a read is not matched to a name in the file, MEGAN will also try to assign the
read using the builtin algorithm.

9 Comparison of samples

Multiple samples can be opened simultaneously and then displayed together in a comparison view, by se-
lecting the File→Compare... menu item. The samples are presented in a composite comparison
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document.

10 Main Window

TheMain window is used to display the taxonomy and to control the program via the main menus. Initially,
at startup, before reopening or creating a new RMA file, the Main window displays the NCBI taxonomy.
By default, the taxonomy is only drawn to its third level. Parts of the taxonomy, or the full taxonomy, can
be explored using the menu items of the window.

Once a data set has been read in, the full NCBI taxonomy is replaced by the taxonomy that is induced by
the data set. The size of nodes indicates the number of reads that have been assigned to the nodes using the
algorithm described in Section 7.3.

Double-clicking on a node will produce a textual report stating how many reads have been assigned to the
corresponding taxon and how many reads have been assigned in total to the taxon and to any of the taxa
below the given node in summary.

Subtrees can be collapsed and expanded, as described below. Most windows in MEGAN provide access to
their functionality through menus, a tool bar that contains a selection of the menu items, and popup menus
that also provide contextual access to menu items.

We now discuss all menus of the Main window.

10.1 The File Menu

The File menu contains the following items:

• The File→New... item: Open a new empty document.

• The File→Open... item: Open a MEGAN file (ending on .rma, .meg or .megan).

• The File→Open Recent submenu (Section 10.2).

• The File→Open From Server... item: Open the Server Browser window to allow
access to files hosted on an instance of MeganServer.

• The File→Compare... item: Open the Compare dialog to produce a comparison of multiple
datasets.

• The File→Import From BLAST... item: Show the Import Blast dialog.

• The File→Import submenu (Section 10.3).

• The File→Meganize DAA Files... item: Opens dialog for meganizing one or more
Diamond DAA files.

• The File→Save As... item: Save current data set.

• The File→Export Image... item: Export content of window to an image file.
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• The File→Export Legend... item: Export content of legend window.

• The File→Export submenu (Section 10.4).

• The File→Page Setup... item: Setup the page for printing.

• The File→Print... item: Print the main panel.

• The File→Extract To New Document... item: Extract all reads and matches on or
below selected node(s) to a new document. This works only on RMA6 and DAA files. Older RMA
files (for example, as generated by MEGAN5) are not supported.

• The File→Extract Reads... item: Extract reads for the selected nodes.

• The File→Properties... item: Show document properties.

• The File→Close item: Close the window.

• The File→Quit item: Quit the program (Windows and Linux only).

10.2 The Open Recent Submenu

The Open Recent menu allows the user to reopen recently opened files.

10.3 The Import Submenu

The Import menu contains the following items:

• The Import→CSV Format... item: Load data in delimiter-separated-values (CSV) format:
READ-NAME,CLASS-NAME,SCORE or CLASS,COUNT(,COUNT...).

• The Import→BIOM Format... item: Import data from a table in BIOM 1 format (see http:
//biom-format.org/documentation/format-versions/biom-1.0.html and Sec-
tion 5.7).

• The Import→Metadata... item: Import a metadata mapping file (as defined in http:
//qiime.org/documentation/file_formats.html).

10.4 The Export Submenu

The Export menu contains the following items:

• The Export→CSV Format... item: Export assignments of reads to nodes to a CSV (comma
or tab-separated value) file.

• The Export→BIOM Format... item: Export data in BIOM 1 format (see http://biom-
format.org/documentation/format-versions/biom-1.0.html and Section 5.7).
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• The Export→STAMP Format... item: Export data in STAMP format. Load the resulting
.spf STAMP profile file together with an exported Metadata file (see next menu item) into the
STAMP analysis program using the STAMP "load data" menu item. When using this feature to export
taxonomic data, you will be asked whether to save all selected nodes in a single “level” (as defined
in STAMP), or whether to “save all levels above the selected nodes” as well. In the latter case, all
official taxonomic ranks above the the most specific rank selected will be exported to STAMP. Note,
however, that only the counts for the selected nodes are exported to STAMP. To also include counts
assigned to higher level taxa, either save each rank separately as a single level STAMP file, or

• The Export→Metadata... item: Export a metadata mapping file (as defined in
http://qiime.org/documentation/file-formats.html).

• The Export→Taxonomic Paths... item: Export assignments of reads weighted taxonomic
paths.

• The Export→Tree... item: Export induced tree (in Newick format).

• The Export→Reads... item: Export all reads to a text file (or only those for selected nodes, if
any selected).

• The Export→Matches... item: Export all matches to a text file (or only those for selected
nodes, if any selected).

• The Export→Alignments... item: Calculate and export alignments for all selected leaves.

• The Export→Gene-Centric Assembly... item: Compute and export a “gene-centric
assembly” of reads for all selected nodes.

• The Export→MEGAN Summary File... item: Export as summary file.

10.5 The Edit Menu

The Edit menu contains the following items:

• The Edit→Cut item: Cut.

• The Edit→Copy item: Copy.

• The Edit→Copy Image item: Copy image to clipboard.

• The Edit→Copy Legend item: Copy legend image to clipboard.

• The Edit→Paste item: Paste.

• The Edit→Edit Node Label item: Edit the node label.

• The Edit→Edit Edge Label item: Edit the edge label.

• The Edit→Description... item: Edit or show the description of the data.

• The Edit→Format... item: Format nodes and edges.
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• The Edit→Find... item: Open the find toolbar.

• The Edit→Find Again item: Find the next occurrence.

• The Edit→Colors... submenu.

• The Edit→Preferences submenu.

10.6 The Colors Submenu

The Colors menu contains a number of different color tables to choose from. In addition, the menu
contains the following items:

• The Colors→Color By Labels item: each label is assigned a color from the chosen color
table and this choice is maintained accross multiple windows and samples.

• The Colors→Color By Position item: items are colored according to their position in a
chart, e.g. the first bar in a bar chart gets the first color from the chosen color table, etc.

• The Colors→Color Samples By Attributes item: using the Sample Viewer, each
sample can be colored by the value of a selected attribute, e.g. if samples have a time point attribute,
then samples can be colored by time point.

• The Colors→Color Taxa by Rank... item: choose a taxonomic rank to color taxa. For
example, in a word cloud showing species, one can color the labels by the genus of the species.

• The Colors→Use Program Colors... item: by default, MEGAN mantains a separate
color table and choice of colors for each document. Select this item to make MEGAN use a single
color table for all documents. This is useful if you want to change some of the assignments of colors
to taxa or functions, say, and then to use the changed colors on multiple documents.

UEThe UE contains a number of additional color tables.

10.7 The Preferences Submenu

The Preferences menu contains the following items:

• The Preferences→Show Notifications item: use this to turn off notifications e.g. when
running MEGAN remotely.

• The Preferences→Accession Parsing submenu.

• The Preferences→Taxon Disabling submenu.

• The Preferences→Use Alternative Taxonomy... item: Open alternative taxon-
omy.tre and taxonomy.map files.

• The Preferences→Use Default NCBI Taxonomy item: Open default NCBI taxonomy.

17



10.8 The Accession Parsing Submenu

The Accession Parsing menu contains the following items:

• The Acession Parsing→First Word Is Accession item: Set this if the first word in
a reference sequence header line is an accession number without any prefix. NCBI is transitioning to
this new format.

• The Acession Parsing→Set Accession Tags item: Use this to specify how accessions
are identified. For example, a RefSeq accession number is usually preceded by ref|.

10.9 The Fix Taxon Mapping Submenu

The Fix Taxon Mapping menu contains the following items:

• The Fix Taxon Mapping→Add A Change... item: Change the taxon name to taxon id
mapping for a given taxon.

• The Fix Taxon Mapping→List All Changes... item: List all changes.

• The Fix Taxon Mapping→Clear All Changes... item: Clear all changes.

10.10 The Preferences Disabling Submenu

The Taxon Disabling menu contains the following items:

• The Taxon Disabling→Enable All item: Enable all taxa.

• The Taxon Disabling→Disable... item: Disable all selected taxa or all named ones.

• The Taxon Disabling→Enable... item: Enable all selected taxa or all named ones.

• The Taxon Disabling→List Disabled... item: List all disabled taxa.

10.11 The Select Menu

The Select menu contains the following items:

• The Select→All Nodes item: Select nodes.

• The Select→None item: Deselect all nodes.

• The Select→From Previous Window item: Select from previous window.

• The Select→All Leaves item: Select all leaves (except Not Assigned, No Hits and Low
Complexity).
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• The Select→All Internal Nodes item: Select all internal nodes.

• The Select→All Intermediate Nodes item: Select all intermediate nodes.

• The Select→Subtree item: Select subtree.

• The Select→Leaves Below item: Select all leaves below currently selected nodes.

• The Select→Nodes Above item: Select all nodes above the currently selected nodes.

• The Select→Invert item: Invert selection.

• The Select→Taxonomic Rank submenu.

10.12 The Taxonomic Rank Submenu

The Taxonomic Rank menu contains the following items:

• The Taxonomic Rank→Domain item: Select Domain.

• The Taxonomic Rank→Phylum item: Select Phylum.

• The Taxonomic Rank→Class item: Select Class.

• The Taxonomic Rank→Order item: Select Order.

• The Taxonomic Rank→Family item: Select Family.

• The Taxonomic Rank→Genus item: Select Genus.

• The Taxonomic Rank→Species item: Select Species.

10.13 The Options Menu

The Options menu contains the following items:

• The Options→Change LCA Parameters... item: Rerun the LCA analysis with different
parameters.

• The Options→Set Number Of Reads... item: Set the total number of reads in the
analysis (will initiate recalculation of all classifications).

• The Options→Project Assignments To Rank... item: Project all taxonomic assign-
ments to a specific taxonomic rank, in a new document.

• The Options→List Summary... item: List summarized counts for nodes selected of tree.

• The Options→List Paths... item: List path from root to node for all selected.

• The Options→Compute Core Biome... item: Determine taxa and functions that appear
in a majority of the samples.
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• The Options→Shannon-Weaver Index... item: Compute the Shannon-Weaver diversity
index.

• The Options→Simpson-Reciprocal Index... item: Compute the Simpson-Reciprocal
diversity index.

• The Options→Open NCBI Web Page... item: Open NCBI Taxonomy web site in browser.

• The Options→Inspect... item: Inspect the read-to-taxon assignments.

10.14 The Layout Menu

The Layout menu contains the following items:

• The Layout→Show Legend item: Show horizontal or vertical legend, or hide.

• The Layout→Increase Font Size item: Set the font size.

• The Layout→Decrease Font Size item: Decrease the font size.

• The Layout→Expand/Contract submenu.

• The Layout→Layout Labels item: Layout labels.

• The Layout→Scale Nodes By Assigned item: Scale nodes by number of reads assigned.

• The Layout→Scale Nodes By Summarized item: Scale nodes by number of reads sum-
marized.

• The Layout→Set Max Node Height... item: Set the maximum node height in pixels.

• The Layout→Zoom To Selection item: Zoom to the selection.

• The Layout→Fully Contract item: Contract tree vertically.

• The Layout→Fully Expand item: Expand tree vertically.

• The Layout→Draw Circles item: Draw data as circles.

• The Layout→Draw Pies item: Draw data as pie charts.

• The Layout→Draw Coxcombs item: Draw data as coxcombs.

• The Layout→Draw Bars item: Draw nodes as bars.

• The Layout→Draw Heatmaps item: Draw data as heat maps.

• The Layout→Linear Scale item: Show values on a linear scale.

• The Layout→Sqrt Scale item: Show values on square-root scale.

• The Layout→Log Scale item: Show values on log scale.
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• The Layout→Rounded Cladogram item: Draw tree as rounded cladogram with all leaves
positioned as right as possible.

• The Layout→Cladogram item: Draw tree as cladogram with all leaves aligned right.

• The Layout→Rounded Phylogram item: Draw tree as rounded phylogram with all leaves
positioned as left as possible.

• The Layout→Phylogram item: Draw tree as phylogram with all leaves positioned as left as
possible.

• The Layout→Use Magnifier item: Turn the magnifier on or off.

• The Layout→Draw Leaves Only item: Only draw leaves.

• The Layout→Highlight Differences submenu.

10.15 The Expand/Contract Submenu

The Expand/Contract menu contains the following items:

• The Expand/Contract→Expand Horizontal item: Expand canvas horizontally.

• The Expand/Contract→Contract Horizontal item: Contract view horizontally.

• The Expand/Contract→Expand Vertical item: Expand canvas vertically.

• The Expand/Contract→Contract Vertical item: Contract view vertically.

10.16 The Tree Menu

The Tree menu contains the following items:

• The Tree→Collapse item: Collapse nodes.

• The Tree→Collapse at Level... item: Collapse all nodes at given depth in tree.

• The Tree→Collapse At Taxonomic Rank submenu.

• The Tree→Collapse All Others item: Collapse all parts of tree that are not above or below
the selected nodes.

• The Tree→Uncollapse item: Uncollapse selected nodes.

• The Tree→Uncollapse Subtree item: Uncollapse whole subtree beneath selected nodes.

• The Tree→Uncollapse All item: Uncollapse all nodes.

• The Tree→Hide Low Support Nodes... item: Hide all nodes that have low support.
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• The Tree→Show Names item: Determine what to label nodes with.

• The Tree→Show IDs item: Display the NCBI ids of taxa.

• The Tree→Show Number of Reads Assigned item: Display the number of reads assigned
to a taxon.

• The Tree→Show Number of Reads Summarized item: Display the total number of hits
to a taxon and its descendants.

• The Tree→Node Labels On item: Show labels for selected nodes.

• The Tree→Node Labels Off item: Hide labels for selected nodes.

• The Tree→Show Intermediate Labels item: Show intermediate labels at nodes of degree
2.

10.17 The Collapse At Taxonomic Rank Submenu

The Collapse At Taxonomic Rank menu contains the following items:

• The Collapse At Taxonomic Rank→Domain item: Collapse Domain.

• The Collapse At Taxonomic Rank→Phylum item: Collapse Phylum.

• The Collapse At Taxonomic Rank→Class item: Collapse Class.

• The Collapse At Taxonomic Rank→Order item: Collapse Order.

• The Collapse At Taxonomic Rank→Family item: Collapse Family.

• The Collapse At Taxonomic Rank→Genus item: Collapse Genus.

• The Collapse At Taxonomic Rank→Species item: Collapse Species.

10.18 The Window Menu

The Window menu contains the following items:

• The Window→About... item: Display the ’about’ window (Windows and Linux only).

• The Window→Check For Updates... item: Check for updates.

• The Window→How to Cite... item: Show how to cite the program.

• The Window→Website... item: Go to the program website.

• The Window→Message Window... item: Open the message window.

• The Window→Reset Window Location item: Reset the location of a window.
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• The Window→Set Window Size... item: Set the window size.

• The Window→Inspector Window... item: Open inspector window.

• The Window→Show Alignment... item: Show alignment of reads to a specified reference
sequence.

• The Window→Main Viewer... item: Brings the main viewer to the front.

• The Window→Open INTERPRO2GO Viewer... item: Open InterPro2GO viewer.

• The Window→Open EGGNOG Viewer... item: Open EGGNOG viewer.

• The Window→Open SEED Viewer... item: Open SEED viewer.

• The Window→Open KEGG Viewer... item: Open KEGG (version 2011) viewer.

UEThe Ultimate Edition contains the latest KEGG classification. Additional menu items for opening user
defined viewers.

• The Window→Open SEED Viewer... item: Open SEED viewer.

• The Window→Sample Viewer... item: Opens the Sample Viewer.

• The Window→Groups Viewer... item: Show groups viewer.

• The Window→Chart... item: Show chart.

• The Window→Chart Microbial Attributes... item: Chart microbial attributes.

• The Window→Cluster Analysis... item: Open a cluster analysis window.

• The Window→Rarefaction Analysis... item: Compute and chart a rarefaction curve
based on the leaves of the tree shown in the viewer.

UE

• The Attribute Correlation Plot... item: Show an Attribute Correlation plot between
attributes and taxa or functional classes.

• The Window→Correlation Plot... item: Show a Correlation plot between taxa or
functional classes.

10.19 Popup Menus

Many of the menu items listed above are also available through context-specific popup menus, which are
activated by a right mouse click.
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10.20 The Toolbar

The toolbar contains the following items:

• The Open... item: Open a MEGAN file (ending on .rma, .meg or .megan).

• The Print... item: Print the main panel.

• The Export Image... item: Export content of window to an image file.

• The Find... item: Open the find toolbar.

• The Expand Vertical item: Expand canvas vertically.

• The Contract Vertical item: Contract view vertically.

• The Expand Horizontal item: Expand canvas horizontally.

• The Contract Horizontal item: Contract view horizontally.

• The Fully Contract item: Contract tree vertically.

• The Fully Expand item: Expand tree vertically.

• The Rounded Cladogram item: Draw tree as rounded cladogram with all leaves positioned as
right as possible.

• The Cladogram item: Draw tree as cladogram with all leaves aligned right.

• The Rounded Phylogram item: Draw tree as rounded phylogram with all leaves positioned as
left as possible.

• The Phylogram item: Draw tree as phylogram with all leaves positioned as left as possible.

• The Collapse item: Collapse nodes.

• The Uncollapse item: Uncollapse selected nodes.

• The Uncollapse Subtree item: Uncollapse whole subtree beneath selected nodes.

• The Domain item: Collapse Domain.

• The Phylum item: Collapse Phylum.

• The Class item: Collapse Class.

• The Order item: Collapse Order.

• The Family item: Collapse Family.

• The Genus item: Collapse Genus.

• The Species item: Collapse Species.
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• The Draw Circles item: Draw data as circles.

• The Draw Pies item: Draw data as pie charts.

• The Draw Coxcombs item: Draw data as coxcombs.

• The Draw Bars item: Draw nodes as bars.

• The Draw Heatmaps item: Draw data as heat maps.

• The Linear Scale item: Show values on a linear scale.

• The Sqrt Scale item: Show values on square-root scale.

• The Log Scale item: Show values on log scale.

• The Chart... item: Show chart.

• The Word Cloud... item: Show word cloud.

• The Radial Tree... item: Show radial chart.

• The Comparison Plot... item: Plot pairwise comparison of assignments to classes.

• The Inspect... item: Inspect the read-to-taxon assignments.

• The Show Alignment... item: Show alignment of reads to a specified reference sequence.

• The Extract Reads... item: Extract reads for the selected nodes.

• The Rarefaction Analysis... item: Compute and chart a rarefaction curve based on the
leaves of the tree shown in the viewer.

• The Chart Microbial Attributes... item: Chart microbial attributes.

• The Main Viewer... item: Brings the main viewer to the front.

• The Open INTERPRO2GO Viewer... item: Open InterPro2GO viewer.

• The Open EGGNOG Viewer... item: Open eggNOG viewer.

• The Open SEED Viewer... item: Open SEED viewer.

• The Open KEGG Viewer... item: Open KEGG viewer.

• The Cluster Analysis... item: Open a cluster analysis window.

• The Sample Viewer... item: Opens the Sample Viewer.

• The Time Series Viewer... item: Opens the Time Series Viewer.

• The Show Legend item: Show horizontal or vertical legend, or hide.
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10.21 The MEGAN Menu

Under MacOS, there is an additional, standard menu associated with the program, called the MEGAN menu.
As usual, this contains the Window→About... and File→Quit menu items.

10.22 Wheel Mouse and Special Keys

Use of a wheel mouse is recommended for zooming of graphics displayed in different windows. The default
is vertical zoom. For horizontal zoom, additionally press the shift key.

To scroll the graph, either press and drag the mouse (using the right mouse button), or use the arrow keys. To
zoom the graph in verticial or horizontal direct, press the shift-key while using the arrow keys. To increase
the zoom factor, additionally press the alt key or the control key.

To select a region of nodes using the mouse, click, hold for a second until the cursor changes to an arrow
and then drag the mouse to capture the nodes to be selected.

11 Sample Viewer

The Sample Viewer provides a tabular view of all samples present in a document. The samples can
have multiple attributes and these attributes can be modified. They can also be used to color the samples.
Samples can be extracted or merged in a number of different ways.

The Sample Viewer has a number of specific menus:

11.1 The Attributes Menu

The Attributes menu contains the following items:

• The Attributes→Set Color... item: Set the color for all selected items.

• The Attributes→Set Value... item: Set value for all selected items.

• The Attributes→New... item: Create a new attribute (column) in the data table.

• The Attributes→Import From File... item: Import one or more attributes from a file
into the data table.

• The Attributes→Duplicate... item: Duplicate an existing attribute (column).

• The Attributes→Rename... item: Rename an existing attribute (column).

• The Attributes→Delete... item: Delete an existing attribute (column).

• The Attributes→Select All Same item: Select all cells that have the same attribute and
value.

26



• The Attributes→Compare Absolute item: Compare samples based on the values of a
selected attribute. For example, if the attribute is gender and there are some selected samples with
value f and others with value m, then this menu item opens a new comparison document in which two
new composite samples labeled gender:f and gender:m are compared with each other.

• The Attributes→Compare Relative item: Same as previous item, except that new samples
are scaled so as to have the same size as the smallest new sample.

11.2 The Samples Menu

The Samples menu contains the following items:

• The Samples→Node Shape submenu.

• The Samples→Group Nodes item: Group selected nodes in PCoA plot.

• The Samples→Ungroup All item: Ungroup nodes in PCoA plot.

• The Samples→Add... item: Add samples from open document.

• The Samples→Add From File... item: Add samples from another document.

• The Samples→Open RMA File... item: Open the original source RMA file or MEGAN-
server file.

• The Samples→Show All item: Show all samples.

• The Samples→Show Selected item: Show selected samples.

• The Samples→Hide Selected item: Hide selected samples.

• The Samples→Hide Unselected item: Hide samples.

• The Samples→Duplicate... item: Duplicate selected samples (rows).

• The Samples→Rename... item: Rename selected samples (rows).

• The Samples→Delete... item: Delete an existing sample (row).

• The Samples→Move Up item: Move Up.

• The Samples→Move Down item: Move samples down.

• The Samples→Set Color... item: Set the color for all selected samples.

• The Samples→Color By Attribute item: Color samples by attribute states.
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11.3 The Node Shape Submenu

The Node Shape menu contains the following items:

• The Node Shape→Circle item: Circle node shape.

• The Node Shape→Square item: Square node shape.

• The Node Shape→Triangle item: Triangle node shape.

• The Node Shape→Diamond item: Diamond node shape.

11.4 The Algorithms Menu

The Algorithms menu contains the following items:

• The Algorithms→Extract Samples... item: Extract selected samples to a new docu-
ment.

• The Algorithms→Compute Core Biome... item: Determine taxa and functions that
appear in a majority of the selected samples.

• The Algorithms→Compute Total Biome... item: Determine total (union) taxonomic
and functional content of the selected samples.

• The Algorithms→Compute Rare Biome... item: Determine taxa and functions that
appear in a minority of the selected samples.

• The Algorithms→Resample... item: Resample selected samples to a new document.

12 Cluster Analysis Viewer

TheCluster Analysis viewer provides methods for comparing multiple samples. It can be opened for
any comparison document containing at least four samples. The Cluster Analysis viewer allows one to com-
pute a distance matrix on the set of samples, based either on their taxon profiles, or based on their functional
classification (for example SEED or KEGG) profiles. The viewer provides a number of different ecological
indices to compute the distances. By default the distances are based on the leaves of the corresponding tree,
however, if some nodes of the tree are selected, then only those nodes are used in the calculation.

The calculated distances are displayed as a PCoA plot (principle coordinates analysis), a hierarchical clus-
tering (UPGMA tree), an unrooted tree (Neighbor-Joining tree) or an unrooted split network (Neighbor-net),
see [16] for details.

MEGAN also computes and displays biplot vectors in a PCoA plot . These vectors indicate which taxa or
functional groups have the largest influence in PCoA plot. MEGAN is able to show both a two dimensional
PCoA and a three dimensional PCoA plot.
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When viewing a three dimensional PCoA plot, click and drag the mouse to roll the plot around. To rotate it,
in addition, press the control key. To slide it, in addition, press the alt key.

UEThe Ultimate Edition contains a perspective three-dimensional PCoA plot based on JavaFX.

The cluster viewer has a number of specific menus:

12.1 The Cluster Analysis Viewer Edit Menu

The Cluster Analysis Viewer Edit menu contains the following items:

• The Edit→Copy item: Copy the current data.

• The Edit→Copy Image item: Copy the current data as an image.

• The Edit→Copy Legend item: Copy legend image to clipboard.

• The Edit→Paste item: Paste the current data.

• The Edit→Format... item: Format nodes and edges.

• The Edit→Node Shape submenu.

• The Edit→Group Nodes item: Group selected nodes in PCoA plot.

• The Edit→Ungroup All item: Ungroup nodes in PCoA plot.

• The Edit→Find... item: Open the find toolbar.

• The Edit→Find Again item: Find the next occurrence.

12.2 The Cluster Analysis Node Shape Submenu

The Node Shape menu contains the following items:

• The Node Shape→Circle item: Circle node shape.

• The Node Shape→Square item: Square node shape.

• The Node Shape→Triangle item: Triangle node shape.

• The Node Shape→Diamond item: Diamond node shape.
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12.3 The Cluster Analysis Viewer Select Menu

The Cluster Analysis Viewer Select menu contains the following items:

• The Select→All item: Select all nodes.

• The Select→None item: De-select nodes.

• The Select→Invert item: Invert selection of nodes.

• The Select→From Previous Window item: Select from previous window.

12.4 The Cluster Analysis Viewer Layout Menu

The Cluster Analysis Viewer Layout menu contains the following items:

• The Layout→Show Legend item: Show horizontal or vertical legend, or hide.

• The Layout→Increase Font Size item: Set the font size.

• The Layout→Decrease Font Size item: Decrease the font size.

• The Layout→Expand/Contract submenu.

• The Layout→Zoom to Fit item: Zoom to fit.

• The Layout→Flip Horizontally item: Flip horizontally.

• The Layout→Flip Vertically item: Flip vertically.

• The Layout→Rotate submenu.

• The Layout→Show Groups item tells MEGAN to indicate groups using ellipses.

• The Layout→Show Groups as Convex Hulls item tells MEGAN to indicate groups using
convex hulls.

• The Layout→Use Colors item: Use colors.

• The Layout→Show Labels item: Show node labels.

• The Layout→Set Node Radius... item: Set node radius.

• The Layout→PC1 vs PC2 item: Set principle components to use.

• The Layout→PC1 vs PC3 item: Set principle components to use.

• The Layout→PC2 vs PC3 item: Set principle components to use.

• The Layout→PCi vs PCj... item: Set principle components to use.

• The Layout→PC1 PC2 PC3 item: Display first three principle components.

• The Layout→PCi PCj PCk... item: Display three principle components.
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12.5 The Rotate Submenu

The Rotate menu contains the following items:

• The Rotate→Rotate Left item: Rotate 3D PCoA plot left.

• The Rotate→Rotate Right item: Rotate 3D PCoA plot right.

• The Rotate→Rotate Up item: Rotate 3D PCoA plot up.

• The Rotate→Rotate Down item: Rotate 3D PCoA plot down.

12.6 The Cluster Analysis Viewer Options Menu

The Cluster Analysis Viewer Options menu contains the following items:

• The Options→Triangulation Test item runs the triangulation test that is applicable for
a set of biological replicates that each is represented by multiple technical replicates. The triangu-
lation test seeks to reject the null hypothesis that all samples come from the same distribution. The
alternative hypothesis is that technical replicates for a given biological sample all come from the same
distribution, but the distributions are different for different biological samples. A paper describing
this new test is in preparation (Huson, Steel et al).

• The Options→Use Normalized Goodall item: Use normalized Goodall’s ecological index.

• The Options→Use Goodall item: Use Goodall’s ecological index.

• The Options→Use Chi-Square item: Use ChiSquare ecological index.

• The Options→Use Kulczynski item: Use Kulczynski ecological index.

• The Options→Use Bray-Curtis item: Use Bray-Curtis ecological index.

• The Options→Use Hellinger item: Use Hellinger ecological index.

• The Options→Use Euclidean item: Use Euclidean ecological index.

• The Options→Use Pearson item: Use Pearson’s correlation distance.

• The Options→Use JSD item: Use square root of Jensen-Shannon divergence (see Arumugam
et al. 2011).

• The Options→Sync item: Sync view of data.
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12.7 The Cluster Analysis Viewer View Menu

The Cluster Analysis Viewer View menu contains the following items:

• The View→PCoA item: Open the PCoA tab.

• The View→UPGMA Tree item: Open the UPGMA tree tab.

• The View→NJ Tree item: Open the NJ tree tab.

• The View→Network item: Open the network tab.

• The View→Matrix item: Open the matrix tab.

• The View→Show BiPlot item: Show biplot loading vectors.

• The View→BiPlot Size... item: Set the number of bi-plot vectors to show.

• The View→Show TriPlot item: Show tri-plot loading vectors.

• The View→TriPlot Size... item: Set the number of tri-plot vectors to show.

12.8 The Cluster Analysis Viewer Toolbar

The Cluster Analysis Viewer toolbar contains the following additional items not included in the Main View
toolbar:

• The PC1 vs PC2 item: Set principle components to use.

• The PC1 vs PC3 item: Set principle components to use.

• The PC2 vs PC3 item: Set principle components to use.

• The PCi vs PCj... item: Set principle components to use.

• The PC1 PC2 PC3 item: Display first three principle components.

• The PCi PCj PCk... item: Display three principle components.

• The Shape item: Change selected nodes to circle, square, triangle or diamond node shape.

• The Group Nodes item: Group selected nodes in PCoA plot.

• The Ungroup All item: Ungroup nodes in PCoA plot.

• The Sync item: Sync view of data.

13 Import from Blast Dialog

The Import Blast dialog is used to import new data from BLAST (or a similar tool) and to create a
new RMA file. The dialog has a number of tabbed panes.
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13.1 Files Tab

The Files Tab is used to setup the location of the input and output files. The program allows to open more
than one BLAST file or reads files, for the case that reads and matches are spread across multiple files.
Please note that all reads must have unique names (where the name of a read is the first word of hits header
line) and all BLAST matches associated with a given read must appear consecutively within a BLAST file.
If the matches associated with a given read are located in different parts of a file or even in different files,
then MEGAN will not be able to handle this gracefully and a messy error may occur. The first item is used
to specify the location of the BLAST file or a similar comparison file in a BLAST-like or SAM format.
Once the file has been specified, MEGAN will attempt to detect the type of the file provided. If the program
is unsuccessful at this, then use the dropdown menus to set the file type and the datatype stored in the file.
The second item is used to specify the location of the reads file.

Use the Long Reads to activate MEGAN’s long read mode (introduced with version 6.7.0 early 2017).

If the reads are from a paired-read project, then selecting the Paired reads check box will request
MEGAN to perform a paired-read analysis. Paired reads are expected to have the same first word in their
header line, only differing in a suffix of length≥, the length of which the user is asked to specify, if selecting
the paired-read mode (or not differing at all).

This is how MEGAN honors paired reads during taxonomic assignment (currently, paired reads information
is not used in functional analysis). Consider a pair of reads r and s. Let A and B be the taxa assigned to
r and s by the LCA algorithm, respectively. If taxon A is undefined because r has no alignments, then we
set A = B, and vice versa. Now assume that both A and B are defined. If A lies on or above B in the
taxonomy, that is, if B is more specific than A, then both reads are assigned to B, and vice versa. Finally,
if A and B are incomparable, that is, they both lie in different parts of the taxonomy, then both r and s are
assigned to the LCA of A and B.

The third item is used to specify the location of the new RMA file. The Max number of matches per read
item specifies how many matches per read to save in the RMA file. A small value will reduce the size of
the RMA file, but may exclude some important matches. By default, the 100 highest scoring matches per
read are saved.

The fourth item allows the user to enter a one-line description of the sample. This will appear as a
Description attribute in the samples Sample Viewer.

Once this information has been collected, the user should review the other panels, as described below, before
pressing the Apply button to import the data.

13.2 Taxonomy Tab

The Taxonomy Tab is used to specify how MEGAN identifies taxa in BLAST output or a similar file. By
default, the program attempts to parse taxon names. Additionally, a mapping file that maps NCBI accession
ids to taxon ids can be used (suffix .map or .abin), or a file that maps GI accession numbers to taxon ids
(suffix .map or .bin), or a file that maps arbitrary strings (“synonyms”) to taxon ids.

Files ending on .map are text files. Each line contains two items, separated by a tab. The first item is the
accession number, GI number, or synonym, respectively, and the second number is the corresponding taxon
id.
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Files ending on .bin are simple binary files for looking up GI to taxon ids. The taxon id associated with a
given GI number n is located at position 4n in the file.

Files ending on .abin represent a disk-based hash table that maps accession numbers (such as
NP_660210) to taxon ids.

Accession and GI mapping files are available from the MEGAN download website.

13.3 InterPro2GO Tab

The InterPro2GO Tab is used to specify how MEGAN identifies InterPro classes in a BLAST or similar file.
If reference sequence header lines contains statemetns of the form IPR123456, then MEGAN can parse
these directly. Otherwise, please download and use an appriopriate mapping file form the MEGAN website.

13.4 eggNOG Tab

The eggNOG Tab is used to specify how MEGAN identifies eggNOG classes in a BLAST or similar file.
The program requires specification of a mapping file to identify eggNOG or COGs. The MEGAN website
supplies an accession to eggNOG mapping file. You can also specify a file that maps GI accession numbers
to eggNOG ids, or a file that maps arbitrary strings (“synonyms”) to eggNOG ids. See Taxonomy Tab for a
brief description of file formats.

13.5 SEED Tab

The SEED Tab is used to specify how MEGAN identifies SEED functional roles in a BLAST or similar
file. The program requires specification of a mapping file to identify SEED classes. The MEGAN website
supplies an accession to SEED mapping file. You can also specify a a file that maps arbitrary strings
(“synonyms”) to SEED ids. Note that the SEED ids used by MEGAN are not official ids. See Taxonomy
Tab for a brief description of file formats.

13.6 KEGG Tab

TheKEGG Tab is used to specify how MEGAN identifies KEGG KO groups in a BLAST or similar file. The
program requires specification of a mapping file to identify KEGG classes. The MEGAN website supplies
an accession to KEGG mapping file. You can also specify a a file that maps arbitrary strings (“synonyms”)
to KEGG ids. See Taxonomy Tab for a brief description of file formats.

UEIf the user has defined additional classifications, then corresponding configuration tabs will appear here.

13.7 LCA Parameters Tab

The LCA Parameters Tab contains most of the items of the Parameters dialog (see Section ref-
sec:Parameters Dialog) which allows one to set the parametersnused by the LCA algorithm. Note paired
reads is activated using Paired reads button in the Files Tab.
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Because re-computation of an analysis at a later stage can take quite long on a large sample, we recommend
that you set these values appropriately before starting the import process.

14 Inspector Window

The Inspector Window can be used to inspect the alignments that are the basis of the assignment of
reads to taxa. It can be opened either using the Window→Inspector Window... menu item or
by right-clicking on a taxon and then selecting the Inspect popup item. This window displays data
hierarchically using a data tree. The root node of this tree represents the current input file. This window can
only be opened when data has been loaded into the program.

Any taxon added to the window, either by right-clicking a taxon and then selecting the Inspect popup
item in the main viewer, or by using the Edit→Show Taxon item, is shown at a second level below
the root. In a similar way you can add specific reads by using the Edit→Show Reads item, which will
allow you to select reads by specifying a regular expression matching the read names. Clicking on a taxon
node will open a new level of nodes, each read node representing a read that has been assigned to the named
taxon. Clicking on a read node will then open a new level of nodes, each such read hit node representing an
alignment of the given read to a sequence associated with some taxon. Finally, double-clicking on a read hit
node will display the actual BLAST alignment provided to deduce the relationship.

14.1 Inspector Menus

Here we describe those menu items that are different from the main window.

14.2 The Inspector Edit Menu

The Edit menu contains the following items:

• The Edit→Cut item: Cut from inspector.

• The Edit→Copy item: Copy.

• The Edit→Paste item: Paste.

• The Edit→Clear item: Clear the selected nodes, or all, if none selected.

• The Edit→Find... item: Open the find toolbar.

• The Edit→Find Again item: Find the next occurrence.

• The Edit→Show Taxon... item: Show the named taxon and all reads assigned to it.

• The Edit→Show Reads... item: Show all reads whose names match the given regular
expression.
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14.3 The Inspector Options Menu

The Options menu contains the following items:

• The Options→Collapse item: Collapse the selected nodes, or all, if none selected.

• The Options→Expand item: Expand the selected nodes, or all, if none selected.

• The Options→Sort Reads Alphabetically item: Sort reads alphabetically.

15 Rarefaction Window

The Rarefaction Window is used to compute and draw a species rarefaction plot.
This operates by repeatedly sampling subsets from a set of reads and computing the num-
ber of leaves to which taxa have been assigned. This analysis uses the current leaves of
the taxonomy, in other words collapsing or uncollapsing nodes will lead to a different result.

UEThere are two properties that can be set: Use setprop NumberRareFactionDataPoints=〈number〉
to set the number of datapoints to be plotted for each sample. Use setprop
NumberRareFactionReplicates=〈number〉 to set the number of replicates to be used for
each datapoint.

Here we describe those Rarefaction Window menu items that are different from the main window.

15.1 The Rarefaction Window Edit Menu

The Edit menu contains the following items:

• The Edit→Cut item: Cut.

• The Edit→Copy item: Copy.

• The Edit→Copy Image item: Copy image to clipboard.

• The Edit→Copy Legend item: Copy legend image to clipboard.

• The Edit→Paste item: Paste.

• The Edit→Select All item: Selection.

• The Edit→Select None item: Deselect all.

• The Edit→Select Top... item: Select top items only.

• The Edit→From Previous Window item: Select from previous window.

• The Edit→Show All item: Show data items.

• The Edit→Show Selected item: Show selected data items.
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• The Edit→Hide Unselected item: Hide unselected data items.

• The Edit→Hide Selected item: Hide selected data items.

• The Edit→Set Color... item: Set the color of a series or class.

• The Edit→Find... item: Open the find toolbar.

• The Edit→Find Again item: Find the next occurrence.

15.2 The Rarefaction Window Options Menu

The Options menu contains the following items:

• The Options→Set Title... item: Set the chart title.

• The Options→Set Series Label... item: Set the series label of the data set.

• The Options→Set Classes Label... item: Set the classes label of the data set.

• The Options→Set Counts Label... item: Set the counts label of the data set.

• The Options→Linear Scale item: Show values on a linear scale.

• The Options→Sqrt Scale item: Show values on square-root scale.

• The Options→Log Scale item: Show values on log scale.

• The Options→Percentage Scale item: Show values as percentage assigned.

15.3 The Rarefaction Window Layout Menu

The Layout menu contains the following items:

• The Layout→Font submenu.

• The Layout→Show Legend item: Show chart legend.

• The Layout→Show Values item: Show values as text.

• The Layout→Show x-Axis item: Show the x-axis.

• The Layout→Show y-Axis item: Show the y-axis.

• The Layout→Use Jitter item: Jitter points in 2D plot to make them more visible.

• The Layout→Rectangle Shape item: Set wordcloud shape.

• The Layout→Show Internal Labels item: Show internal labels in Radial Chart.
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• The Layout→Set Max Radius... item: Set the max radius to use for nodes in a co-
occurrence plot.

• The Layout→Labels Standard item: Category labels drawn standard.

• The Layout→Labels Up 45o item: Category labels drawn upward in 45o angle.

• The Layout→Labels Down 45o item: Category labels drawn downward in 45o angle.

• The Layout→Labels Up 90o item: Category labels drawn upward in 90o angle.

• The Layout→Labels Down 90o item: Category labels drawn downward in 90o angle.

• The Layout→Expand Horizontal item: Expand view.

• The Layout→Contract Horizontal item: Contract view.

• The Layout→Expand Vertical item: Expand view vertically.

• The Layout→Contract Vertical item: Contract view vertically.

• The Layout→Zoom To Fit item: Zoom to fit.

• The Layout→Rotate Left item: Rotate Radial Chart left.

• The Layout→Rotate Right item: Rotate Radial Chart right.

• The Layout→Transpose item: Transpose the chart.

15.4 The Rarefaction Window Font Submenu

The Font menu contains the following items:

• The Font→Title Font... item: Set the font used for the title.

• The Font→X-Axis Font... item: Set the font used for the x-axis.

• The Font→Y-Axis Font... item: Set the font used for the y-axis.

• The Font→Legend Font... item: Set the font used for values.

• The Font→Values Font... item: Set the font used for values.

• The Font→Draw Font... item: Set the font used for drawing.

16 Chart Window

There is one chart window per document per type of analysis.
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16.1 Taxon Chart Window

The Taxon Chart Window is used to visualize the abundance distribution of the taxa as a (stacked) bar
chart, brick chart, bubble chart, co-occurrence network, heat map, (stacked) line chart, pie chart radial
space filling tree, or word cloud.

More recent visualizations include an attribute correlation plot and a correlation plot. These two, and the
heat map, all also allow clustering of rows or columns based on correlation.

It can be opened using the Window→Chart... menu item. To present a specific set of taxa in the chart,
select them in the main window and then press the sync button in the chart window tool bar.

The co-occurrence network is controlled by a number of parameters. The threshold sets the minimum count
required for a taxon to be considered present in a sample. Themin prevalenceandmax prevalenceparameters
are used to set the minimum and maximum percentage of samples in which a taxon can occur, respectively,
so as to have the taxon to be presented by a node in the network. The probablity sets parameter defines the
minimum probability that a co-occurrence between two taxa A and B must attain so as to be represented by
an edge in the graph. The probability of coocurrence is computed as the number of samples that contain
both A and B, divided by the number number of samples that contain either A or B.

For a document containing multiple samples, by default, the chart viewer groups by sample. Use the
Transpose tool bar button to produce a transposed chart in which the chart viewer groups by taxon
or functional group.

Charts can be set to a linear scale, square-root scale, log scale or percent scale. In the latter case, percentages
reported are always percentage over all selected nodes, on a sample-by-sample basis. (This was not the case
in previous version of MEGAN, when in a transposed view the percentage was relative to the given class,
which didn’t make sense.)

MEGAN uses the concept of a Color Table to decide which colors to use in a chart and provides a number
of different color tables for the user to choose from. Also, the user can decide to Color by Label or Color by
Position. In the former case each class is assigned a specific color that is the same across all windows of all
documents using the same color table. In the latter case, colors are assigned by position in the chart (e.g.,
first bar in a bar chart is given the first color etc).

The Attribute Correlation plot shows correlation coefficients between different pairs of taxa or functional
groups and attributes (aka “metadata”) as “coffee beans” (ellipses), squares, circles or numbers. The Cor-
relation plot shows correlation coefficients between different pairs of taxa or functional groups as “coffee
beans” (ellipses), squares, circles or numbers. The Heat Map plot supports a z-disjointScore analysis with
clustering by samples and by taxa or functional groups. In this visualization, cells are colored so as to rep-
resent z-disjointScore. Distances between rows/cols are computed as 1-Pearson’s correlation coefficent and
rows/cols are clustered using UPGMA applied to these distances.

17 InterPro2GO Window

The InterPro2GO window is used to display a InterPro2GO analysis of gene function, based on [2]
and [15]. The classification is displayed as a tree. Genes are mapped onto InterPro identifiers and these are
placed in a GO-based tree.
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Modes of interaction and available menu items are similar to those of the main window. The window is split
into two panes. The right pane contains a tree-based display of the result of the InterPro2GO classification.
The left pane contains two tabs, one containing a textual tree-based view and the other using a heat-map
style listing of the current leaf nodes of the tree displayed in the right pane.

18 eggNOG Window

The eggNOG window is used to display a eggNOG analysis of gene function, based on [20]. The eggNOG
is displayed as a tree. Reads are mapped onto COG and ENOG identifiers, which appear in the tree.

Modes of interaction and available menu items are similar to those of the main window. The window is split
into two panes. The right pane contains a tree-based display of the result of the COG classification. The left
pane contains two tabs, one containing a textual tree-based view and the other using a heat-map style listing
of the current leaf nodes of the tree displayed in the right pane.

19 SEED Window

The SEED window is used to display a SEED analysis of gene function, based on [18]. The SEED
classification is displayed as a tree. Genes are mapped onto functional roles and these are present in one or
more subsystems. Modes of interaction and available menu items are similar to those of the main window.

The window is split into two panes. The right pane contains a tree-based display of the result of the SEED
classification. The left pane contains two tabs, one containing a textual tree-based view and the other using
a heat-map style listing of the current leaf nodes of the tree displayed in the right pane.

20 KEGG Window

The KEGG window is used to display a KEGG analysis of gene function, based on [12]. Due to licensing
restrictions, the tree used in the Community Edition dates to early 2011.

The KEGG classification is displayed as a tree. Genes are mapped onto enzymes and these are present in one
or more pathways. Modes of interaction and available menu items are similar to those of the main window.

The window is split into two panes. The right pane contains a tree-based display of the result of the KEGG
classification. The left pane contains two tabs, one containing a textual tree-based view and the other using
a heat-map style listing of the current leaf nodes of the tree displayed in the right pane.

UEThe Ultimate Edition comes with a license to use latest version of KEGG within MEGAN. We provide an
uptodate GI to KEGG mapping file and the program contains all KEGG pathways.
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21 Extending Mapping Files

MEGAN requires mapping files that map reference sequences to taxonomic and/or functional classes. The
program supports three types, GI mapping files, RefSeq mapping files and Synonyms mapping files. A GI
mapping file maps GI numbers (with prefix gi|) to taxonomic or functional identifiers, i.e. taxon ids and
e.g. KEGG KO numbers. Similarly, a RefSeq mapping file maps RefSeq identifiers (with prefix ref|) to
taxa or functions.
Reference databases such as the NCBI-nr database often contain many different GI numbers and/or RefSeq
ids per reference sequence and thus define an equivalence relationship among these identifiers. The Ulimate
Edition of MEGAN provides a program called extend-mapping that takes as input a mapping file and a
reference database (such as NCBI-nr) in fasta format and generates a new extended mapping file that takes
all equivalences into account.) The program can be found in tools/utils.
For example, suppose that you have generated a gi to InterPro mapping file and assume that you have down-
loaded the latest version of NCBI-nr from ftp://ftp.ncbi.nih.gov/blast/db/FASTA/nr.gz.
Then, to extend the mapping file gi2interpro.bin, run the following command:

~/megan/tools/utils/extend-mapping -v -r nr.gz -g2i gi2interpro.bin
-og2i gi2interpro.map -b true

This will produce two extended GI to InterPro mapping files, gi2interproX.map (text format) and
gi2interproX.bin (binary format, created because we used the option -b true). Use the binary
mapping file in MEGAN or meganizer, when memory is limited and disk access is fast, otherwise, use the
text file. Using an extended file should substantially increase the number of reads that can be assigned to the
corresponding classification (in the case of this example, InterPro).
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22 User-defined Classifications

In MEGAN Ultimate Edition, users can define and use their own classifications. To generate a classifier, a
tab separated mapping file (.map) assigning the classifiers IDs to GI identifiers is needed, as well as a naming
file, assigning names to the classifiers IDs. Additionally the hierarchical structure of the classifiers has to be
provided as a tree (.tre) in Newick format. From these three files, a classifier for MEGAN can be generated
and used in a similar way as the predefined functional classifications. Each user defined classification is
displayed as a tree. Modes of interaction and available menu items are similar to those of the main window.
The window is split into two panes. The right pane contains a tree-based display of the result of the classi-
fication. The left pane contains two tabs, one containing a textual tree-based view of the hierarchy and the
other using a heat-map style listing of the current leaf nodes of the tree displayed in the right pane.
As an example of this, we provide a PFAM analyzer based on the PFAM classification of gene function [8].
The PFAM classification is displayed as a tree. Genes are assigned to protein families, which are clustered
in clans of related families. Modes of interaction and available menu items are similar to those of the main
window.
The window is split into two panes. The right pane contains a tree-based display of the result of the PFAM
classification. The left pane contains two tabs, one containing a textual tree-based view and the other using
a heat-map style listing of the current leaf nodes of the tree displayed in the right pane.

23 Alignment Viewer

The Alignment Viewer is used to compute and visualize a multiple sequence alignment of all reads
that have significant matches to a reference sequences associated with a given taxon, SEED class or KEGG
class. It can be opened using the Window→Show Alignment... menu item or by right-clicking on
a taxon and then selecting the Show Alignment... popup item. Here is an overview of the menus
available in this viewer and those menu items that do not appear in the main viewer.

23.1 The Alignment Viewer Export Submenu

The Export submenu in the File menu of the Alignment Viewer contains the following items:

• The Export→Alignment... item: Save alignment to a file.

• The Export→Consensus... item: Export consensus sequence to a file.

• The Export→Reference... item: Export reference sequence to a file.

• The Export→Overlap Graph... item: Build and export the overlap graph for selected
nodes.

• The Export→Gene-Centric Assembly item: Run gene-centric assembly on all reads in
current alignment and save contigs to file.
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23.2 The Alignment Viewer Edit Menu

The Edit menu contains the following items:

• The Edit→Cut item: Cut.

• The Edit→Copy item: Copy.

• The Edit→Paste item: Paste.

• The Edit→Copy Alignment item: Copy.

• The Edit→Copy Consensus item: Copy selected consensus sequence to clipboard.

• The Edit→Copy Reference item: Copy selected reference sequence to clipboard.

• The Edit→Copy Read Names item: Copy the names of selected reads to the clip-board.

• The Edit→Select All item: Select all cells of the alignment.

• The Edit→Select None item: Select none of the cells of the alignment.

• The Edit→From Previous Window item: Select from previous window.

• The Edit→Find... item: Open the find toolbar.

• The Edit→Find Again item: Find the next occurrence.

• The Edit→Find Read... item: Find and select a read using a regular expression.

• The Edit→Preferences submenu.

23.3 The Alignment Viewer Preferences Submenu

The Preferences menu contains the following items:

• The Preferences→Set Minimum Number of Reads... item: Globally set the mini-
mum number of aligned reads required for a reference sequence to be listed in the alignment viewers.

23.4 The Alignment Viewer Options Menu

The Options menu contains the following items:

• The Options→Move Up item: Move selected sequences up.

• The Options→Move Down item: Move selected sequences down.

• The Options→Translate... item: Translate sequenced DNA or cDNA sequence.

• The Options→Chart Diversity... item: Chart diversity ratio.
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• The Options→Show Insertions item: Show insertions in reads.

• The Options→Contract Gaps item: Contract all columns consisting only of gaps.

• The Options→Show Nucleotides item: Show nucleotides in alignment.

• The Options→Show Amino Acids item: Show amino-acids in alignment.

• The Options→Show Reference item: Show reference sequence.

• The Options→Show Consensus item: Show consensus sequence.

• The Options→Show Unaligned item: Show the unaligned prefix and suffix of reads.

• The Options→Set Amino Acid Colors... item: Set the color scheme for amino acids.

• The Options→Matches Vs Reference item: Color letters that match the reference se-
quence.

• The Options→Mismatches Vs Reference item: Color letters that do not match the refer-
ence sequence.

• The Options→Matches Vs Consensus item: Color letters that match the consensus se-
quence.

• The Options→Mismatches Vs Consensus item: Color letters that do not match the con-
sensus sequence.

23.5 The Alignment Viewer Layout Menu

The Layout menu contains the following items:

• The Layout→As Mapping item: Layout sequences as mapped.

• The Layout→By Start item: Layout sequences by their start positions.

• The Layout→By Name item: Layout sequences alphabetically by their names.

• The Layout→By Contigs item: Layout sequences by assembled contigs.

• The Layout→Unsorted item: Layout sequences in unsorted order.

• The Layout→Expand/Contract submenu.

• The Layout→Zoom To Fit item: Zoom to fit.

• The Layout→Expand To Height item: Expand to readable height.

• The Layout→Reset Zoom item: Reset.

• The Layout→Zoom To Selection item: Zoom to selection.
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The minimum overlap required to assemble two reads aligned to the same refer-
ence into a contig is 20 bp (as used in the Layout→By Contigs menu
item). At present, this is a program property (i.e., not document specific).

UEIt can be changed to 40, for example, by entering the command setprop AssemblyMinOverlap=40
using the Window→Command Input... window.

By default, the alignment viewer only shows as many positions as covered by alignments.
To show additional positions at the end of the alignment, enter the following command
setprop alignmentViewerAdditionalPositions=〈number〉 using the Window→Command
Input... menu item.

24 Group Viewer

The Group Viewer is used to define or display groups of samples.

25 Find Toolbar

The Find toolbar can be opened using the Edit→Find... item. Its purpose is to find taxa, genes or
other strings in a window. Use the following check boxes to parametrize the search:

• If the Whole words only item is selected, then only taxa or reads matching the complete query
string will be returned.

• If the Case sensitive item is selected, then the case of letters is distinguished in comparisons.

• If the Regular Expression item is selected, then the query is interpreted as a Java regular
expression.

• Use the Uncollapse... item to allow MEGAN to search for taxa among currently collapsed
nodes.

Press the Close, First or Next buttons to close the toolbar, or find the first, or next occurrence of the
query, respectively. Press the All button to find all occurrences of the query.

Press the From File button (marked by a file image) to load a set of queries, one per line, from a text file.

26 Format Dialog

The Format dialog is opened using the Edit→Format... item. This is used to change the font,
color, size and line width of all selected nodes and edges. Also, it is used to turn labels on and off.
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27 Message Window

The Message window is opened using the Window→Message Window... item. The program
writes all messages to this window. The window contains the usual File and Edit menu items.

28 Parameters Dialog

The Parameters dialog is used to control the basic parameters of the LCA-assignment algorithm. It
can be invoked by selecting Options→Change LCA Parameters... . The dialog options in the
Parameters tab are:

• The Min Score item is used to set a minimum threshold for the bit disjointScore of alignments or
“hits”. Any hit in the input data that scores less than the given threshold is ignored.

• The Max Expected item is used to set a maximum threshold for the expected value of hits. Any
hit in the input data whose E-value exceeds this value is ignored.

• The Min Percent Identity item is used to set a minimum percent identity for alignments.

• The Top Percent item is used to set a threshold for the maximum percentage by which the
disjointScore of a hit may fall below the best disjointScore achieved for a given read. Any hit that
falls below this threshold is discarded.

• The Min Support item is used to set a threshold for the minimum support that a taxon requires,
that is, the number of reads that must be assigned to it so that it appears in the result. Any read that is
assigned to a taxon that does not have the required support is pushed up the taxonomy until a node is
found that has sufficient support.

• The Min Support Percent item is used to set a threshold for the minimum support that a
taxon requires, as a percentage of assigned reads. This feature is turned off by setting the value to
0. If a value greater than 0 (and at most 100) is given, then the program will set the Min Support
threshold appropriately. The Min Complexity item is used to identify low complexity reads
[23, 17]. These are placed on a special Low Complexity node. To turn this filter off, set the value to 0.
A value of 0.3 catches most low complexity short reads.

• The Select LCA Algorithm item is used to select the LCA algorithm.

• The Use Read Magnitudes item tells the program to parse and use read magnitudes or weights
that are specified in the read header lines.

• The Use 16S Percent Identity Filter item is used to turn on an additional filter for
assigning reads to a specific taxonomic level. When this is active, the percent identity of a match must
exceed the given value of percent identity to be assigned at the given rank: Species 99%, Genus 97%,
Family 95%, Order 90%, Class 85%, Phylum 80%. This should only be used when analyzing 16S
rRNA sequences.

• The Paired Reads item is used to turn paired-read awareness of MEGAN on and off. In paired-
read mode, MEGAN utilities read-pairing information to enhance the taxonomic assignment of reads.
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UEThe default percent threshold used by the weighted LCA algorithm is 75%, you can change
this globally using the command By default, the algorithm does not assign reads to taxa be-
low the species rank, you can remove this restriction globally using the command setprop
allowWeightedLCABelowSpecies=〈boolean〉.

29 Compare Dialog

The Compare dialog is opened using the File→Compare... item. This dialog provides a list of cur-
rently open samples and also allows one to add files that are not currently open. To construct a comparison,
select at least two different samples and then press “Apply”. Select Use Absolute Counts , if you
want the comparison the original counts of reads for each sample. Select Use Normalized Counts , if
you want all counts to be normalized to the smallest number of reads of any of the selected samples. Select
Ignore all unassigned reads , if you want all reads assigned to the three special nodes labeled
’Not Assigned’, ’No Hits’ and ’Low Complexity’ (if present) to be ignored.

The result of this process is a comparison document that contains all classification data and metadata
associated with the original input files, but not their reads or alignments.

30 Extractor Dialog

This provides an alternative to the Export→Reads... item which allows to save reads from different
taxa to files whose names contain the taxon name.

The Extractor dialog is opened using the File→Extract Reads... item. The dialog is used
to extract all reads assigned to selected nodes. For any selected nodes, all reads assigned to it are saved to a
file. By selecting the Include Summarized Reads checkbox you not only extract all reads assigned
to the selected node, but also the reads assigned to all nodes below them.

Use the Browse button to specify the output directory. Specify the file name for output in the File name
field. If the name contains %t, then the program will produce one output file per node, and the name of the
file is generated by replacing %t by the node name. Otherwise, all reads are written to one file.

31 Export Image Dialog

TheExport Image dialog is opened using the File→Export Image... item. This dialog is used
to save a picture of the current tree in a number of different formats.

The format is chosen from a menu. There are two radio buttons Save whole image to save the whole
image, and Save visible image to save only the part of the image that is currently visible in the
main viewer. If the chosen format is EPS, then selecting the Convert text to graphics check box
will request the program to render all text as graphics, rather than fonts.

Pressing the apply button will safe the graphics file to the location given in the File field.
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32 About Window

The About Window is opened using the Window→About... item. It shows the program’s splash
screen.

33 Server Browser Window

The Server Browser window is opened using the File→Open From Server... menu item.

The window is used to connect MEGAN to one or more MeganServer instances, allowing the user to open
MEGAN files that are stored remotely on a server.

MeganServer is a light-weight server program, written by Hans-Joachim Ruscheweyh, that runs on a server
and provides access to selected RMA files on the server via a REST interface. (See the documentation for
MeganServer for details).

Use the Server Browser:Add server tab to connect to a new remote server.

For example, set the server to http://megan-db.org/Public, and the user and password both to
guest to access 12 MEGAN RMA files computed for the samples described in [14], as well as other
example datasets.

Once an instance of MeganServer has been successfully contacted, a directory tree will be displayed that
mirrors the directory structure of the server. Double-clicking on a file name will open that file. To open a
comparison document for multiple files, select the files of interest and then press the Compare button.

A currently opened server will have its own tab in the Server Browser, until it is closed by selecting
the Close remote server toolbar item.

MEGAN will remember previously contacted MeganServer instances and thus previously opened files can
be directly reopened using the Open Recent menu. If you do not want this to happen without MEGAN
requesting the confidentials for the server again, you can deselect the Save credentials checkbox
when first connecting to the server.

34 File Formats

MEGAN uses its own file formats to store the data describing the result of a sequence comparison compu-
tation between a file of DNA reads and a database of reference sequences, such as computed by BLASTX,
BLASTP or BLASTN [1].

34.1 RMA Files

Files ending in .rma are in a compressed binary format called RMA (read-match archive), which is a new
open format that we will describe in a separate document. MEGAN 1 used a text format (files ending on
.megan or .meg), which are now deprecated and will not be supported by futher versions of the program.
By convention, we use the suffix .megan for MEGAN text files and .rma for binary read-match archive
files.
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With MEGAN 4, we introduced a new version of the RMA format, internally known as RMA 2. This format
was more flexible, as it does not necessarily need to contain all reads and matches. Moreover, it has better
locality and thus updating it is much faster.

MEGAN uses another update of the RMA file format, known as RMA6. Older RMA file versions can still
be opened in MEGAN, but RMA6 files are not compatible with previous versions. RMA6 requires only a
third of the space that RMA2 does. Internally, it uses a compression version of the SAM format.

A RMA file is generated using the File→Import From BLAST... menu item from a BLAST file
and a read file (or from multiple files, if the reads are spread across multiple files).

34.2 The Text File Summary Format

A MEGAN file starts with a number of header lines, each starting with a . These lines can occur in any order.
This is best illustrated by an example:

1 @Creator MEGAN (version 4.0alpha20, built 14 Oct 2010)
2 @CreationDate Wed Oct 27 17:10:52 CEST 2010
3 @ContentType Summary4
4 @Names 155_PE_1_fixed-paired ecoli-testrun-2000-nr
5 @Uids 1288068180866 1288190195887
6 @Sizes 51246 2000
7 @TotalReads 200000
8 @Collapse SEED 2000041
9 @Algorithm Taxonomy tree-from-summary
10 @Parameters normalizedTo=100000
11 @NodeStyle KEGG piechart

The first and second lines are optional descriptions of who generated the file when. The third line identifies
the format as Summary4, indicating that this is a summary file in the format introduced with MEGAN 4. The
fourth line lists the names of all samples that are represented by this file. In this case there are two. Line 5 of
this example lists the unique identifier numbers associated with the samples, if any. Line 6 lists the original
sizes of the samples. Line 7 lists the total number of reads. This is not necessary the sum of the original sizes.
Line 8 specifies, for the SEED classification, which nodes are to be collapsed in the visual representation
of the classification. The keyword SEED can be replaced for example by TAXONOMY or KEGG for the
other classifications. Line 9 contains the name of the algorithm used to compute a classification. The second
word here is a keyword to identify which classification is meant. Line 10 lists parameters of the computation
used to generate the file. Line 11 specifies the style used to draw nodes in a given classification, in this case
KEGG.

The main body of a MEGAN text file contains multiple lines as follows:, in any order:

TAX 199310 0 1250
TAX 1 271 100
TAX 28216 35
TAX 32523 8
TAX 2 8336 1350
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KEGG 7716 12
KEGG 3859 2
KEGG 7714 2 100
SEED 54 6 50

The general format is classification, count-1, count-2, ..., count-n. Here, classification is either TAX for
taxonomy, SEED or KEGG. This is followed by a number indicating a class in the given classification. In the
case of taxonomy, this is the NCBI classId. This is followed by up to n numbers, where n is the number of
samples mentioned in the header, indicating how many reads in the 1-st, 2-nd etc sample were assigned to
the given class.

34.3 Required Syntax of BLAST Files

MEGAN imports data from aBLAST file. MEGAN can parse BLAST files (from BLAST and tools producing
comparable output) in standard or XML format obtained using the BLAST output option -m 0 or -m 7,
respectively. MEGAN can also parse tabular format (BLAST output option -m 8). For this to work, the
subject field must either contain taxon names or GI accession numbers. In the latter case, please use the
Load GI-Lookup File button to load a GI lookup file. Alternatively, a ninth column may be supplied
that contains either the taxon name or taxon Id associated with the database sequence. The program also
scans the subject field for RefSeq identifiers to determine the associated gene.

MEGAN can read gzipped BLAST files and zipped BLAST files.

For human readable format, any BLASTX file or BLASTP file is expected to adhere to the format shown in
Figure 1. Any BLASTN file is expected to adhere to the format shown in Figure 2.

34.4 How MEGAN Parses Taxon Names

MEGAN uses the following algorithm to determine the taxon from the header line of a reference sequence.
If the string consists only of an integer, then this is interpreted as a taxon id. Otherwise, if Use Synonyms

is turned on, then MEGAN attempts to match an entry in the given synonyms file. A synonyms file defines
a mapping between words that appear in the match header and taxa or other classes. The longest matching
synonym is used to determine the taxon. Otherwise, if Use GI Lookup is turned on, then MEGAN
searches for an occurrence of the string gi| followed by a number and tries to use the number as a GI
accession to determine the taxon.

Otherwise, if the header line contains a semi-colon, then MEGAN assumes that a list of taxon names is
given, e.g. Bacteria;Proteobacteria; Alpha proteobacteria, as present, for example, in
the Silva database. In this case, MEGAN uses the right-most name to determine the taxon id.

Otherwise, if the header line contains the text /TAXON_ID=, then MEGAN will attempt to read a taxon id
following the text. This syntax is used in BLAST files obtained from the CAMERA website.

Otherwise, MEGAN searches for all pairs of disjoint square brackets and attempts to parse the strings
between such brackets to obtain a set of taxon ids. The taxon id for the match is then set to the LCA of the
ids. (In the NCBI-NR database, names of taxa are placed between square brackets.)

Otherwise, MEGAN searches for maximal and non-overlapping substrings that can be mapped onto an
NCBI taxon id. Again, the taxon id of the match is set to the LCA.
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BLASTX text
text...

followed by 0 or more blocks of the following type:

Query= 〈query-id〉 text length=〈length〉 text
or
Query= 〈query-id〉 text|length|〈length〉|text
text...

followed by 0 or more blocks of the following type:

> text [〈NCBI-taxon-name〉] text
(line breaks ok)

Score = 〈disjointScore〉 bits (〈bits〉 ) Expect = 〈e-value〉
Identities = text (〈percent-identities〉%)
Positives = text (〈percent-positives〉%), Gaps = text (〈percent-gaps〉%)
Frame = 〈frame〉
followed by 0 or more blocks of the following type:

Query text
text
Sbjct text

Figure 1: The required structure of a BLASTX file. Labels shown as label are tokens that must occur
verbatim in the file. Labels shown as 〈label〉 are values that are read into the program. The first word in
the file must be BLASTX. The header line starting with Query =, which is taken from the Fasta header of
the query sequence (a read), must start with a one word unique identifier for the read and must also contain
a statement containing the length of the read, in the format length=〈length〉, or as |length|〈length〉|.
Another important feature is that the comment line of the database sequence must contain a NCBI-taxon
name. If names are not contained in the comment lines, then the accession lookup support must be used.
Finally, the Gaps= statement is optimal.
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BLASTN text
text...

followed by 0 or more blocks of the following type:

Query= 〈query-id〉 text length=〈length〉 text
or
Query= 〈query-id〉 text|length|〈length〉|text
text...

followed by 0 or more blocks of the following type:

> text 〈NCBI-taxon-name〉 text
(line breaks ok)

Score =〈disjointScore〉 bits (〈bits〉 ) Expect =〈e-value〉
Identities = text (〈percent-identities〉%) Gaps = text (〈percent-gaps〉%)
Strand= 〈strand〉 / 〈strand〉

followed by 0 or more blocks of the following type:

Query text
text
Sbjct text

Figure 2: The required structure of a BLASTN file. Labels shown as label are tokens that must occur
verbatim in the file. Labels shown as 〈label〉 are values that are read into the program. The first word in the
file must be BLASTN. The header line starting with Query=, which is taken from the Fasta header of the
query sequence (a read), must start with a one word unique identifier for the read and must also contain a
statement containing the length of the read, in the format length=〈length〉. Another important feature is
that the comment line of the database sequence must contain a NCBI-taxon name. If names are not contained
in the comment lines, then the accession lookup support must be used.
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Otherwise, the taxon is set to ’unknown’.

34.5 Required Format of Read Files

Reads from sequencing are assume to be provided in fasta format or fastq format in a reads file. The file (or
files) may be gzipped. The first word of a FastA header is assumed to be the read-id.

34.6 CSV File Format

MEGAN supports importing data from other programs in a comma-separated format from a CSV file, using
the Import→CSV Format... menu item. The input file must be a text file in which either all lines
each contain two strings that are separated by a comma or tab. or all lines each contain three strings separated
by commas or tabs.

Importing read assignments If each line of the CSV file contains two strings separated by a comma, then
the first string will be intepreted as a taxon name or taxon id and the second string will be intepreted as an
integer specifying the number of reads assigned to the named taxon. MEGAN will assume that this is the
result of some analysis and thus will produce a summary file from it and will simply display it on the NCBI
taxonomy with no further analysis.

For example, assume that you have performed a metagenome analysis using some other method and have
obtained the following result:

• Gammaproteobacteria: 55 reads

• Mollicutes: 400 reads

• Escherichia coli K-12: 42 reads

• Unknown: 100 reads

To import this data into MEGAN so as to visualize the taxonomical assignments, produce the following
CSV file:

Gammaproteobacteria, 55
Mollicutes, 400
Escherichia coli K-12, 42
Not assigned, 100

MEGAN will draw a tree with four nodes, one for each of the named taxa.

Importing read matches Otherwise, if each line of the CSV file contains three strings separated by a
comma, the first string will be interpreted as a read id, the second one as a taxon name or id and the third one
will be interpreted as a bit disjointScore for this assignment. MEGAN will assume that this data describes
a collection of reads and their matches. This data will be analysed using the LCA algorithm and the result
will be displayed on the NCBI taxonomy.
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For example, assume that you have done a database search using some other method than BLAST and have
obtained the following result:

• The read r01 matches Escherichia coli CFT073 with a bitscore of 100,

• The read r01 matches Escherichia coli K-12 with a bitscore of 110, and

• The read r01 matches Salmonella enterica subsp. enterica serovar Choleraesuis str. SC-B67 with a
bitscore of 120.

• The read r02 matches Caldicellulosiruptor saccharolyticus DSM 8903 with a bitscore of 90.

To import this data into MEGAN so as to analyze is using the LCA algorithm, produce the following CSV
file:

r01, Escherichia coli CFT073, 100
r01, Escherichia coli K-12, 110
r01, Salmonella enterica subsp. enterica serovar Choleraesuis str. SC-B67,120
r02, Caldicellulosiruptor saccharolyticus DSM 8903, 90

MEGAN can also import SEED, COD or KEGG counts. In addition, MEGAN is able to map entries
consisting of a RefSeq Id and counts to KEGG, COG or SEED. In the Ultimate Edition this also includes
PFAM.

Use the Multiplier field to set a multipler that is applied to all counts.

34.7 Tree and Map Format

The NCBI taxonomy is loaded by MEGAN at startup. It is contained in a NCBI tree file in the standard
Newick tree format. The mapping from taxon-IDs to taxon names is loaded by MEGAN at startup. It is
contained contained in a NCBI mapping file in a line based format in which each has three entries: taxon-ID,
taxon name and then a number indicating the size of the genome, or -1, if the size is unknown.

35 Command-Line Options

UEThe Ultimate Edition of MEGAN allows to run the program in command-line mode. This and the following
Section 36 only apply to Ultimate Edition.
MEGAN has the following command-line options:

Mode:
-g, --commandLineMode Run MEGAN in command-line mode. Default value: false.

Input:
-f, --files [string(s)] MEGAN file(s) to open.

Commands:
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-x, --execute [string] Command to execute at startup
(do not use for multiple commands).

-c, --commandFile [string] File of commands to execute in command-line mode.

Configuration:
-E, --quitOnException Quit if exception thrown in command-line mode.

Default value: false.
-p, --propertiesFile [string] Properties file. Default value: Megan.def.
+w, --hideMessageWindow Hide message window. Default value: false.
-V, --version Show version string. Default value: false.
-S, --silentMode Silent mode. Default value: false.
-d, --debug Debug mode. Default value: false.
+s, --hideSplash Hide startup splash screen. Default value: false.
-rc, --registrationCode [string] Enter registration code.

Other:
-v, --verbose Echo commandline options and be verbose.

Default value: false.
-h, --help Show program usage and quit.

UEWhen running in command-line mode, the program will first executing any command given with the -x
option and then will read commands from the file specified using the -c command. If no such file is given,
additional commands are read from standard input.
Please note that windows will still open when in command-line mode, but should not be used interactively.
(This is necessary for the program to fully implement all graphical commands.) To prevent windows from
opening, or to use the command-line mode on a server, please use the linux virtual frame buffer command
xvfb-run, as shown here:

xvfb-run --auto-servernum --server-num=1 MEGAN +g

UENew features of MEGAN6 are implemented using JavaFX. Running MEGAN6 on a Linux server requires
that the graphics toolkit GTK2.18 (or later) is installed, e.g. using the following command: apt-get
install xvfb libgtk2.0-0
(There may be problems using libgtk-3-0)
Please be aware that the command-line version of the program uses the same properties file as the interactive
version. So, any preferences set using the interactive version of the program will also apply to the command-
line version of the program. It this is not desired, then please use the -p option to supply a different
properties file.
Another important thing to note is that the command-parser operates in a line-by-line fashion. When pro-
cessing commands in a given line, the parser makes note of required updates to the taxonomy and data-
structures. These updates are not executed until all commands in the current input line have been processed.
For example, if you want to open and MEGAN file and then to save a picture of the taxonomical analysis
in a PDF file, then the two commands should be entered on separate lines because otherwise the taxonomy
will be drawn before the data from the MEGAN file has been processed. Here is an example of the correct
way to produce a picture of a taxonomic analysis:

open file=’/Users/huson/data/megan/x.rma’
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export image file=’/Users/huson/data/megan/x.pdf’ format=PDF replace=true
quit

UEAlternatively, the update command is used to explicitly force MEGAN to update all data-structures, in
this case the commands show appear together on one line, e.g.:

open file=’x.rma’;update;exportimage file=’x.pdf’format=PDF replace=true;

UEAs described below, the update command takes a number of different parameters that is used to determine
exactly what type of update is required.
Please use the -x option only to specify a single command, as updating may otherwise not work correctly.
One example of using MEGAN command-line mode is given in Section 36.1. Other examples and recipes
for command-line scripts performing common use cases of MEGAN are available on the MEGAN commu-
nity website.

36 Command-Line Commands

Each type of window that can be opened by MEGAN has its own command interpreter. Initially, on startup
the program will open a Main window and all commands piped to the program will be executed using the
command interpreter associated with the main window. The main window provides a number of commands
for opening other windows. For example, the command open viewer=SeedViewer; will open the
SEED classification viewer. To pipe commands to the SEED viewer, the command context has to be
set to the SEED viewer, by entering set context=seedviewer;. After entering this command, all
subsequent commands are handled by the interpreter associated with the SEED viewer. To obtain a list of all
commands available for the current interpreter, enter help;. In obtain help on a particular command, for
example on export, enter help export;. All command description lines that contain the word “export”
(case insensitive) will be listed.
In the following we list all commands available in the Main viewer. Other viewers support many of these
commands, too, but also other, viewer-specific ones. To determine which commands are available for a given
window, run MEGAN in GUI mode, open the window of interest and then select the Window→Command
Syntax... item to obtain a listing of all commands available for the given window. Here are the
commands that are available in the Main viewer:

Available commands (context=MainViewer):

File menu:
new; - Open a new empty document
open file=<filename> [readOnly={false|true}]; - Open a MEGAN file (ending on .rma, .meg or .megan)
show window=RemoteBrowser; - Open browser for remote files
show window=ImportBlast; - Show the ’Import from Blast’ dialog
save file=<filename> [summary={true|false}]; - Save current data set
exportImage file=<filename> [descriptionFile=<filename>] [format={bmp|eps|gif|jpg|pdf|png|svg}] [replace={false|true}]
[visibleOnly]={false|true}] [textAsShapes={false|true}] [title=<string>];
- Export content of window to an image file
exportLegend file=<filename> [format={bmp|eps|gif|jpg|pdf|png|svg}] [replace={false|true}] [textAsShapes={false|true}];
- Export content of legend window
show window=pagesetup; - Setup the page for printing
show window=print; - Print the main panel
extract what=document file=<megan-filename> [data={Taxonomy|INTERPRO2GO|EGGNOG|SEED|KEGG|...}]
[ids=<SELECTED|numbers...>] [allBelow={false|true}];
- Extract all reads and matches for all selected nodes to a new document
show window=ExtractReads; - Extract reads for the selected nodes
show window=properties; - Show document properties
close; - Close the window
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Import sub-menu:
import csv={reads|summary} separator={comma|tab} file=<fileName> fNames={Taxonomy|INTERPRO2GO|EGGNOG|SEED|KEGG|...} [topPercent=<num>] [minScore=<num>] [minSupportPercent=<num>] [minSupport=<num>] [multiplier=<number>];
- Load data in CSV (comma- or tab-separated value) format: READ_NAME,CLASS-NAME,SCORE or CLASS,COUNT(,COUNT...)
import format=biom file=<fileName>;
- Import data from a table in BIOM 1.0 format (see http://biom-format.org/documentation/format_versions/biom-1.0.html)
import metaData=<file> [format={metaDataMapping}];
- Import a metadata mapping file (as defined in http://qiime.org/documentation/file_formats.html)

Export sub-menu:
export what=CSV format={format} [separator={comma|tab}] [counts={assigned|summarized}] file=<filename>;
- Export assignments of reads to nodes to a CSV (comma or tab-separated value) file
export format=biom data={{Taxonomy|INTERPRO2GO|EGGNOG|SEED|KEGG|...} file=<filename>;
- Export data in BIOM 1.0 format (see http://biom-format.org/documentation/format_versions/biom-1.0.html)
export metaData=<file> [format={metaDataMapping}];
- Export a metadata mapping file (as defined in http://qiime.org/documentation/file_formats.html)
export what=paths file=<filename>; - Export assignments of reads weighted taxonomic paths
export what=tree file=<filename> [simplify={false|true}] [showInternalLabels={true|false}] [showUassigned={true|false}];
- Export induced tree (in Newick format)
export what=reads [data={{Taxonomy|INTERPRO2GO|EGGNOG|SEED|KEGG|...}] file=<filename>;
- Export all reads to a text file (or only those for selected nodes, if any selected)
export what=matches [data={{Taxonomy|INTERPRO2GO|EGGNOG|SEED|KEGG|...}] file=<filename>;
- Export all matches to a text file (or only those for selected nodes, if any selected)
export what=alignment file=<filename> data={{Taxonomy|INTERPRO2GO|EGGNOG|SEED|KEGG|...} classId={number[,number...]|selected} [asConsensus={false|true}] [asContigs={false|true}]
[useEachReadOnlyOnce={true|false}] [useEachReferenceOnlyOnce={true|false}] [includeInsertions={true|false}]
[refSeqOnly={false|true}] [contractGaps={false|true}] [translateCDNA={false|true}] [minReads={number}] [minLength={number}] [minAvCoverage={number}];
- Calculate and export alignments for all selected leaves
export assembly file=<name> [minOverlap=<number>] [minReads=<number>] [minLength=<number>] [minAvCoverage=<number>] [maxPercentIdentity=<number>] [showGraph={false|true}]
- Compute and export "gene-centric" assembly of reads for all selected nodes

Edit menu:
copyLegend; - Copy legend image to clipboard
set description=<text>; - Edit or show the description of the data
show window=formatter; - Format nodes and edges
show findToolbar={true|false}; - Open the find toolbar

Preferences sub-menu:

Fix Taxon Mapping sub-menu:
changeMapping taxName=<taxon-name> taxId=<taxon-id>;
- Change the taxon name to taxon id mapping for a given taxon
changemapping list; - List all changes
changemapping clear; - Clear all changes

Taxon Disabling sub-menu:
enable taxa=all; - Enable all taxa
disable taxa={selected|<name,...>}; - Disable all selected taxa or all named ones
enable taxa={selected|all|<name,...>}; - Enable all selected taxa or all named ones
list taxa=disabled; - List all disabled taxa

Select menu:
select nodes={all|none|leaves|internal|previous|subtree|leavesBelow|nodesAbove|intermediate|invert}
- Select nodes
select nodes=previous; - Select from previous window

Taxonomic Rank sub-menu:

Options menu:
recompute [minSupportPercent=<number>] [minSupport=<number>] [minScore=<number>] [maxExpected=<number>] [topPercent=<number>] [weightedLCA={false|true}] [lcaCoveragePercent=<number>] [minComplexity=<number>]
[useMinimalCoverageHeuristic={false|true}] [longReads={false|new}] [pairedReads={false|true}] [useIdentityFilter={false|true}]
[fNames={COG|KEGG|PFAM|SEED]; - Rerun the LCA analysis with different parameters
set totalReads=<num>;
- Set the total number of reads in the analysis (will initiate recalculation of all classifications)
project rank={Domain|Kingdom|Phylum|Class|Order|Family|Genus|Species} [minPercent={number}];
- Projects all taxonomic assignments onto a given rank
list summary nodes={all|selected} [outFile=<name>];
- List summarized counts for nodes selected of tree
list paths nodes=selected [outFile=<name>]; - List path from root to node for all selected
compute index={Shannon|SimpsonReciprocal} [data={Taxonomy|SEED|KEGG}];
- Compute the Shannon-Weaver diversity index
compare mode={ABSOLUTE|RELATIVE} [ignoreUnassigned={false|true}] [pid=<number> ...] [meganFile=<filename> ...];
- Open compare dialog to produce a comparison of multiple datasets
show webpage taxon=<name|id>; - Open NCBI Taxonomy web site in browser
inspector taxa=selected; - Inspect the read-to-taxon assignments

Layout menu:
show legend={horizontal|vertical|none}; - Show horizontal or vertical legend, or hide
set fontSize={<number>|increase|decrease}; - Set the font size
set autoLayoutLabels={true|false}; - Layout labels
set scaleBy={Summarized|Assigned|None}; - Scale nodes by number of reads assigned
set maxNodeHeight=<number>; - Set the maximum node height in pixels
zoom selected; - Zoom to the selection
zoom fit; - Contract tree vertically
zoom full; - Expand tree vertically
set nodeDrawer={Summarized|Assigned|None}; - Draw data as pie charts
set scale={linear|percent|log}; - Show values on a linear scale
set magnifier={true|false}; - Turn the magnifier on or off
set drawLeavesOnly={true|false}; - Only draw leaves
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Expand/Contract sub-menu:
expand direction={horizontal|vertical}; - Expand canvas horizontally
contract direction={horizontal|vertical}; - Contract view horizontally

Tree menu:
collapse nodes={SELECTED|name [name name ...]}; - Collapse nodes
collapse level=<num>; - Collapse all nodes at given depth in tree
collapse except={id...}; - Collapse all parts of tree that are not above or below the selected nodes
uncollapse nodes={all|selected|<name ...>} [subtree={false|true}]; - Uncollapse selected nodes
hide minSupport=<number>; - Hide all nodes that have low support
nodeLabels [names=<bool>] [ids=<bool>] [assigned=<bool>] [summarized=<bool>];
- Determine what to label nodes with
show labels=selected; - Show labels for selected nodes
hide labels=selected; - Hide labels for selected nodes
show intermediate=<bool>; - Show intermediate labels at nodes of degree 2

Collapse At Taxonomic Rank sub-menu:

Window menu:
register licenseKey=<string>; - Register a license key
show window=howToCite; - Show how to cite the program
show window=message; - Open the message window
reset windowLocation; - Reset the location of a window
set windowSize=<width> x <height>; - Set the window size
show window=inspector; - Open inspector window
show window=aligner; - Show alignment of reads to a specified reference sequence
show window=mainViewer; - Brings the main viewer to the front
open viewer=INTERPRO2GO; - Open InterPro2GO viewer
open viewer=EGGNOG; - Open eggNOG viewer
open viewer=SEED; - Open SEED viewer
open viewer=KEGG; - Open KEGG viewer
show window=sampleViewer; - Opens the Sample Viewer
show window=timeSeriesViewer; - Opens the Time Series Viewer
show window=groups; - Show groups viewer
show chart drawer={BarChart,BricksChart,BubbleChart,CoOccurrencePlot,HeatMap,LineChart,NormalizedBarChart,PieChart,Plot2D,RadialTreeChart,StackedBarChart,StackedLineChart,WordCloud} data={{Taxonomy|INTERPRO2GO|EGGNOG|SEED|KEGG|...|attributes};
- Show chart
show comparisonPlot [data={{Taxonomy|INTERPRO2GO|EGGNOG|SEED|KEGG|...]};
- Plot pairwise comparison of assignments to classes
show window=clusterViewer; - Open a cluster analysis window
show rarefaction data={{Taxonomy|INTERPRO2GO|EGGNOG|SEED|KEGG|...};
- Compute and chart a rarefaction curve based on the leaves of the tree shown in the viewer
help [keyword(s)]; - Show syntax of commands for current viewer

Additional commands:
addSample [sample=<name>] source=<filename|pid> ... [overwrite={false|true}];
- Add samples from other documents
addServer url=<url> [user=<user>] [password=<password>];
- Add a MEGAN server to the persistent list of known servers
apply majorityVote voteConfidence=<\%ofConfidence>
- Apply a the majority vote filter. Reads with a defined percentage of matches assigned to one taxon will bypass the LCA and assign the read to this taxon.
collapse rank={SuperKingdom|Kingdom|Phylum|Class|Order|Family|Varietas|Genus|Species_group|Species|Subspecies}
- Collapse tree at specific taxonomic rank
compare title=<string> name=<string> samples=<string ...> [name=<string> samples=<string ...>] ... [comparisonMode={ABSOLUTE|RELATIVE}] [ignoreUnassigned={false|true}] ;
- Compare some groups of samples
compute profile={Projection|ReadSpreading} rank={Domain|Kingdom|Phylum|Class|Order|Family|Genus|Species [minPercent=number]};
- Computes a taxonomic profile by projecting all counts on to a given rank
export overlapGraph file=<name> [minOverlap=<number>] [showGraph={false|true}];
- Build and export the overlap graph for selected nodes
export readname2taxpath file=<file>; - Export readname to taxonomic path for all reads
export selected path file=<file>; - Export select Path
export taxonname_count separator={comma|tab} folder=<foldername> - Export assignments
export what=matchPatterns taxon=<id or name> rank=<name> file=<filename>;
- Export all match signatures for the select node
extract samples=<name1 name2 ...>; - Extract samples to a new document
extract what=reads outDir=<directory> outFile=<filename-template> [data={{Taxonomy|INTERPRO2GO|EGGNOG|SEED|KEGG|...}][ids=<SELECTED|numbers...>]
[names=<names...>] [allBelow={false|true}]; - Extract reads for the selected nodes
help [keyword(s)]; - Show syntax of commands for current viewer
import blastFile=<name> [,<name>...] [fastaFile=<name> [,<name>...]] meganFile=<name> format={BlastText|BlastXML|BlastTab|RapSearch2Aln|RDPAssignmentDetails|RDPStandalone|Mothur|SAM|References_as_FastA}
mode={BlastN|BlastP|BlastX|Classifier} [maxMatches=<num>] [minScore=<num>] [maxExpected=<num>]
[topPercent=<num>] [minSupportPercent=<num>] [minSupport=<num>] [lcaAlgorithm={Naive|Weighted|NaiveLongReads}] [lcaCoveragePercent=<num>] [minComplexity=<num>] [useIdentityFilter={false|true}]
[fNames={{Taxonomy|INTERPRO2GO|EGGNOG|SEED|KEGG|......} [paired={false|true} [pairSuffixLength={number}]]
[description=<text>];
- Import BLAST (or RDP or Silva or SAM) and reads files to create a new MEGAN file
list assigned nodes={all|selected} [outFile=<name>]; - List assigned counts for selected nodes of tree
list assignmentsToLevels [outFile=<name>];
- List the number of reads assigned to each level of the taxonomy
listServers; - List all added servers
load colorFile=<filename>; - Load a palette of colors from a file (one RGB color per line)
load mapFile=<filename> mapType=<mapType> cName=<name> [parseTaxonNames={false|true}] ; - Loads a mapping file
load taxonomyFile=<filename> [mapFile=<filename>]; - Load taxonomy.tre and taxonomy.map files
mpAnalyzer what={lca-ranks|compare} infile=<filename> outfile=<filename>;
- Compute the rank at which the LCA is found for each mate-pair, or preprocess comparison
open viewer=KEGG; - Open KEGG viewer
open viewer=Taxonomy; - Open Taxonomy viewer
queryServer url=<url> query={countFiles|listFiles}; - Query a known server
quit; - Quit the program
remoteServer url=<url>; - Add a MEGAN server to the persistent list of known servers
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scrollTo node=<name>; - Scroll to a specific node
select id=<number> ...; - Select the nodes for the given ids
select name=<name> <name> ... [state={true|false}]; - Select the named nodes
select rank={SuperKingdom|Kingdom|Phylum|Class|Order|Family|Varietas|Genus|Species_group|Species|Subspecies}
- Select nodes by rank
set color={<color>|null}; - Set the color of selected nodes and edges
set context={<window-type>|?};
- Choose command context, i.e. the window that will parse subsequent commands. Use ? to list current context and all available contexts.
set dir=<directory> - Set the current directory
set drawer={RectangularCladogram,RectangularPhylogram,RoundedCladogram,RoundedPhylogram};
- Set the tree drawer
set edgeShape={angular|straight|curved}; - Set the shape of selected edges
set edgeWidth=<integer>; - Set the width of selected edges
set fillColor={<color>|null} - Set the fill color of selected nodes
set font=<name-style-size>; - Set font nodes or edges, e.g. arial-italic-12
set fullScreen={false|true}; - Full Screen Mode
set groupNodes={none|selected}; - Group selected nodes in PCoA plot
set labelColor={<color>|null}; - Set the label color of selected nodes and edges
set labelFillColor={<color>|null}; - Set the label color of selected nodes and edges
set magnifyallmode={true|false}; - Magnify the whole tree
set margin [left=<number>] [right=<number>] [bottom=<number>] [top=<number>];
- Set margins used in tree visualization
set nodeShape={none|circle|square|triangle|diamond}; - Set the node shape
set nodeSize=<integer>; - Set the size of selected nodes
set useMagnitude={true|false};
- Use reads magnitude values to weight reads, if present in their FastA header lines
setProp <name>=<value>; - Set a property
show histogram classId=<num>; - Shows the distribution of matches for a given taxon
show keggTab id=<num,num,...>; - Show the specified KEGG pathway (UE version only, when KEGG license available)
show webpage classification=<name> id=<id>; - Search for selected items in browser
show window=about; - Display the ’about’ window
show window=attributes; - Open Microbial Attributes window
show window=comparisonStats; - Open dialog to produce a statistical comparison of two datasets
toFront [file=name]; - Bring window to front
update [reProcess={false|true}] [reset={false|true}] [reInduce={false|true}]; - Update data
use cViewer=<name> state={true|false}; - Determine whether to perform a specific functional analysis
use mapType=<mapType> cName=<name> state=<true|false>; - Set activity state of map type
version; - Show version info
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36.1 Writing Scripts

The best way to run scripts with MEGAN is to prepare a file of commands and then pipe these to MEGAN
in command-line mode. Use of the -x option to supply commands is not encouraged because of update
issues. MEGAN uses updates all windows etc after a line of commands has been entered and all commands
provided using the -x option are considered to be contained in a single line.
Here is an example of how one would use MEGAN in command-line mode on a Mac to save some informa-
tion on KEGG assignments:
/Applications/Megan/MEGAN.app/Contents/MacOS/JavaApplicationStub -g -E < commands.txt

where the file commands.txt contains the following lines:
open file=’/Users/huson/data/megan/microbiome.rma’; open viewer=EggnogViewer;

set context=EggnogViewer; update; uncollapse nodes=all; select

nodes=leaves; export what=CSV format=eggnogName_count separator=tab

file=’/Users/huson/data/megan/eggnog.txt’; quit;

The first line is used to open a MEGAN file. Please surround the file name with single quotes as shown here.
The second line opens the eggNOG window (or EggnogViewer, as it is referred to here).
The third line sets the command context to the EggnogViewer (so that subsequent commands are interpreted
by the EggnogViewer). The argument of this command is case sensitive. Please use EggnogViewer and
not eggnogviewer.
The fourth line ensures that the eggNOG window is uptodate.
The fifth line uncollapses the whole eggNOG tree.
The sixth line selects all leaves of the eggNOG tree.
The seventh line exports all eggNOG names and read counts to a file in “Delimiter separated format”.
The eight line quits the program.
More examples for using command scripts with MEGAN are available on the Community website.

37 Using More Memory

The MEGAN installer allows you to specify the maximum amount of MEGAN that the program can use.
We recommend at least 4 GB for working with samples on a laptop and recommend that you give MEGAN
32 GB on a server for creating RMA files or meganizing Diamond files.

You can change the maximum amount of memory permitted after installation by editing the file
MEGAN.vmoptions that should be contained in the installation directory, as follows: Edit the amount
of memory mentioned there to reflect the desired amount, e.g. 8 gigabytes:

-Xmx8G

38 MEGAN Tools

The Linux and MacOS distributions of MEGAN have an additional tools directory that contains a number
of standalone utility programs.
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The program sam2rma can be used on a server to generate a RMA file on a server. The input must be one
or more SAM files generated by either DIAMOND or MALT.

The program blast2lca provides a standalone implementation of the LCA algorithm and can also perform
KEGG classification. Input is a BLAST file or similar.

The program blast2rma is similar to the sam2rma program, it is used to generate RMA files from BLAST
output on a server without running MEGAN.

The program daa-meganizer prepares a DIAMOND DAA file for use with MEGAN, a process that we call
meganizing. The program performs taxonomic and functional classification of all reads in the given file and
then appends this information to the end of the file.

UEThe program make-acc2ncbi can be used to create a new accession to taxonomy mapping file
from files downloaded from ftp://ftp.ncbi.nih.gov/pub/taxonomy/accession2taxid.
The program make-gi2ncbi can be used to create a new GI to taxonomy mapping file from a
file such as ftp://ftp.ncbi.nih.gov/pub/taxonomy/gi_taxid_nucl.dmp.gz or ftp:
//ftp.ncbi.nih.gov/pub/taxonomy/gi_taxid_prot.dmp.gz.
The program references-annotator can be used to add taxonomic and functional annotation information to a
file of references before reads are aligned to the references. The annotations can then be parsed directly my
MEGAN or any of the MEGAN tools without the need to use mapping files.
See Section 20 for additional tools.

More tools will follow.
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Files Tab, 33
Find, 45
Find Again, 17, 29, 35, 37, 43
Find Read..., 43
Find..., 17, 24, 29, 35, 37, 43, 45
First, 45
First Word Is Accession, 18
Fix Taxon Mapping, 18
Fix Taxon Mapping→Add A Change..., 18
Fix Taxon Mapping→Clear All Changes..., 18
Fix Taxon Mapping→List All Changes..., 18
Flip Horizontally, 30
Flip Vertically, 30
Font, 37, 38
Font→Draw Font..., 38
Font→Legend Font..., 38
Font→Title Font..., 38
Font→Values Font..., 38
Font→X-Axis Font..., 38
Font→Y-Axis Font..., 38
font, change, 45
Format, 45
Format..., 16, 29, 45
From File, 45
From Previous Window, 18, 30, 36, 43
Fully Contract, 20, 24
Fully Expand, 20, 24
functional roles, 12

Gene-Centric Assembly, 42
Gene-Centric Assembly..., 16
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Genus, 19, 22, 24
GI accession, 50
GI mapping files, 41
GI to taxonomy, 61
Group Nodes, 27, 29, 32
Group Viewer, 45
Groups Viewer..., 23
GTK2.18, 55
guest, 48
gzip format, 7
gzipped BLAST files, 50

heat map, 39
Heat Map plot, 39
Hide Low Support Nodes..., 21
Hide Selected, 27, 37
Hide Unselected, 27, 37
Highlight Differences, 21
horizontal zoom, 26
How to cite, 3
How to Cite..., 22
http://megan-db.org/Public, 48

Ignore all unassigned reads, 47
Import, 14, 15
Import Blast, 32
Import From BLAST..., 5, 14, 49
Import From File..., 26
Import→BIOM Format..., 9, 15
Import→CSV Format..., 15, 53
Import→Metadata..., 15
Include Summarized Reads, 47
Increase Font Size, 20, 30
Inspect, 5, 35
Inspect..., 20, 25
Inspector, 35
Inspector Window..., 23, 35
InterPro2GO, 4, 39
InterPro2GO Tab, 34
Invert, 19, 30

JavaFX, 55

KEGG, 13, 40
KEGG Tab, 34
Kegg tree, 13
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Layout, 20, 37, 44
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Layout→As Mapping, 44
Layout→By Contigs, 44, 45
Layout→By Name, 44
Layout→By Start, 44
Layout→Cladogram, 21
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Layout→Decrease Font Size, 20, 30
Layout→Draw Bars, 20
Layout→Draw Circles, 20
Layout→Draw Coxcombs, 20
Layout→Draw Heatmaps, 20
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Layout→Draw Pies, 20
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Layout→Log Scale, 20
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Layout→PC1 vs PC2, 30
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Layout→PC2 vs PC3, 30

Layout→PCi PCj PCk..., 30
Layout→PCi vs PCj..., 30
Layout→Phylogram, 21
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Layout→Rounded Cladogram, 21
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Layout→Scale Nodes By Assigned, 20
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Layout→Set Max Radius..., 38
Layout→Set Node Radius..., 30
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Layout→Show Internal Labels, 37
Layout→Show Labels, 30
Layout→Show Legend, 20, 30, 37
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Layout→Show x-Axis, 37
Layout→Show y-Axis, 37
Layout→Sqrt Scale, 20
Layout→Transpose, 38
Layout→Unsorted, 44
Layout→Use Colors, 30
Layout→Use Jitter, 37
Layout→Use Magnifier, 21
Layout→Zoom To Fit, 38, 44
Layout→Zoom to Fit, 30
Layout→Zoom To Selection, 20, 44
LCA, 8
LCA Parameters Tab, 34
LCA-assignment algorithm, 11
Leaves Below, 19
Legend Font..., 38
line width, change, 45
Linear Scale, 20, 25, 37
linear scale, 39
Linux, 6
Linux server, 55
List All Changes..., 18
List Disabled..., 18
List Paths..., 19
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List Summary..., 19
Load GI-Lookup File, 50
log file, 9
Log Scale, 20, 25, 37
log scale, 39
long read inspector, 10
Long Read LCA algorithm, 10
long read mode, 10
Long Reads, 33
long reads, 10
Low Complexity, 46

MacOS, 6
MacOS X, 6
magnitudes, 46
Main, 14
Main Viewer..., 23, 25
make-acc2ncbi, 61
make-gi2ncbi, 61
Matches Vs Consensus, 44
Matches Vs Reference, 44
Matches..., 16
Matrix, 32
Max Expected, 46
Max number of matches per read, 33
max prevalence, 39
MEGAN, 26
MEGAN file, 49
MEGAN project, 7
MEGAN Summary File..., 16
MEGAN_COMMUNITY_macos_6.21.2.dmg, 6
MEGAN_COMMUNITY_unix_6.21.2.sh, 6
MEGAN_COMMUNITY_windows-

64x_6.21.2.exe, 6
MEGAN_Ultimate_macos_6.21.2.dmg, 6
MEGAN_Ultimate_unix_6.21.2.sh, 6
MEGAN_Ultimate_windows-64x_6.21.2.exe, 6
Meganize DAA Files..., 14
meganizing, 61
MeganServer, 48
Message, 46
Message Window..., 22, 46
metabolic pathways, 13
Metadata..., 15, 16
metagenome, 3
metagenomics, 3

Metascope, 12
MG-RAST, 9
Min Complexity, 46
Min Percent Identity, 46
min prevalence, 39
Min Score, 8, 46
Min Support, 46
Min Support Percent, 46
minimum overlap, 45
Mismatches Vs Consensus, 44
Mismatches Vs Reference, 44
Move Down, 27, 43
Move Up, 27, 43
Multiplier, 54

NCBI mapping file, 54
NCBI taxonomy, 10
NCBI tree file, 54
NCBI-NR, 10
NCBI-NT, 10
Network, 32
New..., 14, 26
Next, 45
NJ Tree, 32
Node Labels Off, 22
Node Labels On, 22
Node Shape, 27–29
Node Shape→Circle, 28, 29
Node Shape→Diamond, 28, 29
Node Shape→Square, 28, 29
Node Shape→Triangle, 28, 29
node size, change, 45
Node→Inspect, 5, 35
Node→Show Alignment..., 42
Nodes Above, 19
NOGs, 13
None, 18, 30

Open EGGNOG Viewer..., 23, 25
Open From Server..., 14, 48
Open INTERPRO2GO Viewer..., 23, 25
Open KEGG Viewer..., 23, 25
Open NCBI Web Page..., 20
Open Recent, 7, 14, 15
Open RMA File..., 27
Open SEED Viewer..., 23, 25
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Open..., 7, 14, 24
Options, 19, 36, 37, 43
Options→Change LCA Parameters..., 19, 46
Options→Chart Diversity..., 43
Options→Collapse, 36
Options→Compute Core Biome..., 19
Options→Contract Gaps, 44
Options→Expand, 36
Options→Inspect..., 20
Options→Linear Scale, 37
Options→List Paths..., 19
Options→List Summary..., 19
Options→Log Scale, 37
Options→Matches Vs Consensus, 44
Options→Matches Vs Reference, 44
Options→Mismatches Vs Consensus, 44
Options→Mismatches Vs Reference, 44
Options→Move Down, 43
Options→Move Up, 43
Options→Open NCBI Web Page..., 20
Options→Percentage Scale, 37
Options→Project Assignments To Rank..., 19
Options→Set Amino Acid Colors..., 44
Options→Set Classes Label..., 37
Options→Set Counts Label..., 37
Options→Set Number Of Reads..., 5, 19
Options→Set Series Label..., 37
Options→Set Title..., 37
Options→Shannon-Weaver Index..., 20
Options→Show Amino Acids, 44
Options→Show Consensus, 44
Options→Show Insertions, 44
Options→Show Nucleotides, 44
Options→Show Reference, 44
Options→Show Unaligned, 44
Options→Simpson-Reciprocal Index..., 20
Options→Sort Reads Alphabetically, 36
Options→Sqrt Scale, 37
Options→Sync, 31
Options→Translate..., 43
Options→Triangulation Test, 31
Options→Use Bray-Curtis, 31
Options→Use Chi-Square, 31
Options→Use Euclidean, 31
Options→Use Goodall, 31

Options→Use Hellinger, 31
Options→Use JSD, 31
Options→Use Kulczynski, 31
Options→Use Normalized Goodall, 31
Options→Use Pearson, 31
Order, 19, 22, 24
Overlap Graph..., 42

Page Setup..., 15
Paired Reads, 46
Paired reads, 33
paired reads, 33
Parameters, 46
Paste, 16, 29, 35, 36, 43
PC1 PC2 PC3, 30, 32
PC1 vs PC2, 30, 32
PC1 vs PC3, 30, 32
PC2 vs PC3, 30, 32
PCi PCj PCk..., 30, 32
PCi vs PCj..., 30, 32
PCoA, 32
PCoA plot, 28
percent scale, 39
Percentage Scale, 37
PFAM, 42
Phylogram, 21, 24
Phylum, 19, 22, 24
pie chart, 39
Preferences, 17, 43
preferences, 55
Preferences→Accession Parsing, 17
Preferences→Set Minimum Number of Reads..., 43
Preferences→Show Notifications, 17
Preferences→Taxon Disabling, 11, 17
Preferences→Use Alternative Taxonomy..., 17
Preferences→Use Default NCBI Taxonomy, 17
Print..., 15, 24
probability of coocurrence, 39
probablity, 39
Project Assignments To Rank..., 19
properties file, 55
Properties..., 15

QIIME, 9
Quit, 15, 26

radial space filling tree, 39
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Radial Tree..., 25
RAPSearch2, 5
Rarefaction, 36
Rarefaction Analysis..., 23, 25
rarefaction plot, 36
RDP, 8
RDP-Assignment-Detail, 8
RDP-standalone, 8
read file, 49
read hit node, 35
read node, 35
reads file, 53
Reads..., 16, 47
Rectangle Shape, 37
Reference..., 42
references-annotator, 61
RefSeq, 12
RefSeq accession number, 18
RefSeq mapping files, 41
Regular Expression, 45
Rename..., 26, 27
Resample..., 28
Reset Window Location, 22
Reset Zoom, 44
RMA, 48
RMA file, 49
Rotate, 30, 31
Rotate Down, 31
Rotate Left, 31, 38
Rotate Right, 31, 38
Rotate Up, 31
Rotate→Rotate Down, 31
Rotate→Rotate Left, 31
Rotate→Rotate Right, 31
Rotate→Rotate Up, 31
Rounded Cladogram, 21, 24
Rounded Phylogram, 21, 24

SAM, 8
sam2rma, 61
Sample Viewer, 26
Sample Viewer..., 23, 25
Samples, 27
Samples→Add From File..., 27
Samples→Add..., 27
Samples→Color By Attribute, 27

Samples→Delete..., 27
Samples→Duplicate..., 27
Samples→Group Nodes, 27
Samples→Hide Selected, 27
Samples→Hide Unselected, 27
Samples→Move Down, 27
Samples→Move Up, 27
Samples→Node Shape, 27
Samples→Open RMA File..., 27
Samples→Rename..., 27
Samples→Set Color..., 27
Samples→Show All, 27
Samples→Show Selected, 27
Samples→Ungroup All, 27
Save As..., 14
Save credentials, 48
Save visible image, 47
Save whole image, 47
Scale Nodes By Assigned, 20
Scale Nodes By Summarized, 20
SEED, 12, 40
SEED Tab, 34
Select, 18
Select All, 36, 43
Select All Same, 26
Select LCA Algorithm, 46
Select None, 36, 43
Select Top..., 36
Select→All, 30
Select→All Intermediate Nodes, 19
Select→All Internal Nodes, 19
Select→All Leaves, 18
Select→All Nodes, 18
Select→From Previous Window, 18, 30
Select→Invert, 19, 30
Select→Leaves Below, 19
Select→Nodes Above, 19
Select→None, 18, 30
Select→Subtree, 19
Select→Taxonomic Rank, 19
Server Browser, 48
Server Browser:Add server, 48
Set Accession Tags, 18
Set Amino Acid Colors..., 44
Set Classes Label..., 37
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Set Color..., 26, 27, 37
Set Counts Label..., 37
Set Max Node Height..., 20
Set Max Radius..., 38
Set Minimum Number of Reads..., 43
Set Node Radius..., 30
Set Number Of Reads..., 5, 19
Set Series Label..., 37
Set Title..., 37
Set Value..., 26
Set Window Size..., 23
Shannon-Weaver Index..., 20
Shape, 32
Show Alignment..., 23, 25, 42
Show All, 27, 36
Show Amino Acids, 44
Show BiPlot, 32
Show Consensus, 44
Show Groups, 30
Show Groups as Convex Hulls, 30
Show IDs, 22
Show Insertions, 44
Show Intermediate Labels, 22
Show Internal Labels, 37
Show Labels, 30
Show Legend, 20, 25, 30, 37
Show Names, 22
Show Notifications, 17
Show Nucleotides, 44
Show Number of Reads Assigned, 22
Show Number of Reads Summarized, 22
Show Reads, 35
Show Reads..., 35
Show Reference, 44
Show Selected, 27, 36
Show Taxon, 35
Show Taxon..., 35
Show TriPlot, 32
Show Unaligned, 44
Show Values, 37
Show x-Axis, 37
Show y-Axis, 37
Silva, 9
silva2ncbi.map, 9
Simpson-Reciprocal Index..., 20

Sort Reads Alphabetically, 36
Species, 19, 22, 24
Sqrt Scale, 20, 25, 37
Square, 28, 29
square-root scale, 39
STAMP, 16
STAMP Format..., 16
STAMP profile file, 16
subsystems, 12
Subtree, 19
Sync, 31, 32
sync, 39
synonyms file, 50
Synonyms mapping files, 41

taxon assignment to matches, 8
Taxon Chart Window, 39
Taxon Disabling, 11, 17, 18
Taxon Disabling→Disable..., 18
Taxon Disabling→Enable All, 18
Taxon Disabling→Enable..., 18
Taxon Disabling→List Disabled..., 18
taxon node, 35
Taxonomic Paths..., 16
Taxonomic Rank, 19
Taxonomic Rank→Class, 19
Taxonomic Rank→Domain, 19
Taxonomic Rank→Family, 19
Taxonomic Rank→Genus, 19
Taxonomic Rank→Order, 19
Taxonomic Rank→Phylum, 19
Taxonomic Rank→Species, 19
Taxonomy Tab, 33
three dimensional PCoA, 28
threshold, 39
Time Series Viewer..., 25
Title Font..., 38
tools directory, 60
Top Percent, 46
Translate..., 43
Transpose, 38, 39
transposed chart, 39
Tree, 21
Tree→Collapse, 21
Tree→Collapse All Others, 21
Tree→Collapse at Level..., 21
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Tree→Collapse At Taxonomic Rank, 21
Tree→Hide Low Support Nodes..., 21
Tree→Node Labels Off, 22
Tree→Node Labels On, 22
Tree→Show IDs, 22
Tree→Show Intermediate Labels, 22
Tree→Show Names, 22
Tree→Show Number of Reads Assigned, 22
Tree→Show Number of Reads Summarized, 22
Tree→Uncollapse, 5, 21
Tree→Uncollapse All, 21
Tree→Uncollapse Subtree, 5, 21
Tree..., 16
Triangle, 28, 29
Triangulation Test, 31
triangulation test, 31
TriPlot Size..., 32
two dimensional PCoA, 28
Type-setting conventions, 3

Ultimate Edition:, 3
Uncollapse, 5, 21, 24
Uncollapse All, 21
Uncollapse Subtree, 5, 21, 24
Uncollapse..., 45
Ungroup All, 27, 29, 32
Unix, 6
Unsorted, 44
update, 56
UPGMA Tree, 32
Use 16S Percent Identity Filter, 46
Use Absolute Counts, 47
Use Alternative Taxonomy..., 17
Use Bray-Curtis, 31
Use Chi-Square, 31
Use Colors, 30
Use Default NCBI Taxonomy, 17
Use Euclidean, 31
Use GI Lookup, 50
Use Goodall, 31
Use Hellinger, 31
Use Jitter, 37
Use JSD, 31
Use Kulczynski, 31
Use Magnifier, 21
Use Normalized Counts, 47

Use Normalized Goodall, 31
Use Pearson, 31
Use Program Colors..., 17
Use Read Magnitudes, 46
Use Synonyms, 50

Values Font..., 38
vertical zoom, 26
View→BiPlot Size..., 32
View→Matrix, 32
View→Network, 32
View→NJ Tree, 32
View→PCoA, 32
View→Show BiPlot, 32
View→Show TriPlot, 32
View→TriPlot Size..., 32
View→UPGMA Tree, 32
virtual frame buffer, 55

Website..., 22
weighted LCA algorithm, 12
weights, 46
Whole words only, 45
Window, 22
Window→About..., 22, 26, 48
Window→Chart Microbial Attributes..., 23
Window→Chart..., 23, 39
Window→Check For Updates..., 22
Window→Cluster Analysis..., 23
Window→Command Input..., 7, 45
Window→Command Syntax..., 56
Window→Correlation Plot..., 23
Window→Groups Viewer..., 23
Window→How to Cite..., 22
Window→Inspector Window..., 23, 35
Window→Main Viewer..., 23
Window→Message Window..., 22, 46
Window→Open EGGNOG Viewer..., 23
Window→Open INTERPRO2GO Viewer..., 23
Window→Open KEGG Viewer..., 23
Window→Open SEED Viewer..., 23
Window→Rarefaction Analysis..., 23
Window→Reset Window Location, 22
Window→Sample Viewer..., 23
Window→Set Window Size..., 23
Window→Show Alignment..., 23, 42
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Window→Website..., 22
Windows, 6
word cloud, 39
Word Cloud..., 25

X-Axis Font..., 38
xvfb-run, 55

Y-Axis Font..., 38

zip format, 7
zipped BLAST files, 50
Zoom To Fit, 38, 44
Zoom to Fit, 30
Zoom To Selection, 20, 44
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